Check-in [1343570ea5]
Not logged in

Many hyperlinks are disabled.
Use anonymous login to enable hyperlinks.

Overview

SHA1 Hash:1343570ea56020b44c1917d5de3716c3df38b264
Date: 2012-06-03 01:30:17
User: BarryK
Comment:version of woof used to build precise puppy 5.2.58 (beta1)

Tags And Properties
Changes

Changes to woof-code/rootfs-skeleton/usr/local/petget/pkg_chooser.sh

@@ -20,10 +20,11 @@
 #120504 some files moved into /tmp/petget
 #120504b improved separation of dev,doc,nls,exe, enhanced ubuntu,debian pkg support.
 #120515 common code from pkg_chooser.sh, findnames.sh, filterpkgs.sh, extracted to /usr/local/petget/postfilterpkgs.sh.
 #120527 change gtkdialog3 to gtkdialog4. icon patterns for postfilterpkgs.sh.
 #120529 ui may show app thumbnail icons.
+#120603 /root/.packages/user-installed-packages missing at first boot.
 
 export TEXTDOMAIN=petget___pkg_chooser.sh
 export OUTPUT_CHARSET=UTF-8
 
 [ "`whoami`" != "root" ] && exec sudo -A ${0} ${@} #110505
@@ -41,10 +42,11 @@
 ICONPTNS="$(ls -1 /usr/share/icons/hicolor/16x16/apps | grep 'xpm$' | sed -e 's%\.xpm$%%' | awk '{print length, $0}' | sort -rn | awk '{$1=""; print $0 }' | sed -e 's%^ %%' | sed -r -e 's%(^[a-z][a-z]$)%^\1%' | sed -r -e 's%(^[a-z]$)%^\1%')"
 echo "$ICONPTNS" > /tmp/petget/postfilter_icon_ptns
 #echo -e 'perl\npython\ntcl\nmail\nkde\nqt\nQt\ndbus\ndb\n' >> /tmp/petget/postfilter_icon_ptns
 
 #120529 app icons
+touch /root/.packages/user-installed-packages #120603 missing at first boot.
 if [ -f /var/local/petget/flg_appicons ];then
  FLG_APPICONS="`cat /var/local/petget/flg_appicons`"
 else
  #test if pet installed with set of 16x16 app icons...
  [ "`grep 'icons_puppy_app' /root/.packages/woof-installed-packages /root/.packages/user-installed-packages`" != "" ] && FLG_APPICONS='true'

Changes to woof-distro/arm/ubuntu/precise/DISTRO_PKGS_SPECS-ubuntu-precise

@@ -235,10 +235,11 @@
 yes|gtk-chtheme|gtk-chtheme|exe,dev>null,doc,nls
 no|gtkdialog2||exe
 yes|gtkdialog3||exe,dev,doc>dev,nls|
 yes|gtkdialog4||exe,dev,doc>dev,nls| #modify all pets that need this to explicitly call gtkdialog or gtkdialog4.
 yes|gtkhash|gtkhash|exe,dev,doc,nls
+yes|gtklp|gtklp|exe,dev,doc,nls
 yes|gtkmm|libgtkmm-2.4-1c2a,libgtkmm-2.4-dev|exe,dev,doc,nls
 no|gtkmoz||exe
 yes|gtk_theme_citrus_cut||exe
 no|gtk_theme_flat_grey||exe
 yes|gtk_theme_flat_grey_rounded||exe

Changes to woof-distro/x86/ubuntu/precise/DISTRO_PKGS_SPECS-ubuntu-precise

@@ -238,10 +238,11 @@
 yes|gtk-chtheme|gtk-chtheme|exe,dev>null,doc,nls
 no|gtkdialog2||exe
 yes|gtkdialog3||exe,dev,doc>dev,nls|
 yes|gtkdialog4||exe,dev,doc>dev,nls| #modify all pets that need this to explicitly call 'gtkdialog' or 'gtkdialog4'.
 yes|gtkhash|gtkhash|exe,dev,doc,nls
+yes|gtklp|gtklp|exe,dev,doc,nls
 yes|gtkmm|libgtkmm-2.4-1c2a,libgtkmm-2.4-dev|exe,dev,doc,nls
 no|gtkmoz||exe
 yes|gtk_theme_citrus_cut||exe
 no|gtk_theme_flat_grey||exe
 yes|gtk_theme_flat_grey_rounded||exe
@@ -459,11 +460,11 @@
 yes|ms-sys||exe
 yes|mtdev|libmtdev1,libmtdev-dev|exe,dev,doc,nls| #needed by synaptics_drv.so in xorg.
 no|mtpaint|mtpaint|exe,dev,doc,nls| #no, very old version (3.34).
 yes|mtpaint||exe,dev,doc,nls
 yes|mtr||exe
-yes|mut2||exe
+no|mut2||exe
 yes|nasm|nasm|exe>dev,dev,doc,nls
 yes|nbtscan|nbtscan|exe
 yes|ncurses|ncurses-base,ncurses-bin,libncurses5,libncurses5-dev,libncursesw5,libncursesw5-dev,libtinfo5,libtinfo-dev|exe,dev,doc,nls
 yes|ndiswrapper|ndiswrapper-common,ndiswrapper-utils-1.9|exe,dev>null,doc,nls
 yes|nenscript||exe