Check-in [2a40c14226]
Not logged in

Many hyperlinks are disabled.
Use anonymous login to enable hyperlinks.

Overview

SHA1 Hash:2a40c142266a1ffe38303c17318fd13746a056d7
Date: 2013-02-03 02:19:09
User: root
Comment:quicksetup: syntax error in xml for gtkdialog

Tags And Properties
Changes

Changes to woof-code/PKGS_MANAGEMENT

@@ -68,11 +68,11 @@
 #these are alternative names for pkgs that are already installed in puppy.
 #this list prevents them from being listed in the package manager gui.
 #problem arises for pet pkgs, where same pkgs in compat-db may have slightly different names.
 
 #alternate names of a package (used in filterpkgs.sh, findpkgs)...
-PKG_NAME_ALIASES='dirac,schroedinger hunspell,myspell mp,mped mplayer,mplayer_* rxvt-unicode,urxvt,urxvt-unicode cxxlibs,glibc*,libc-* gdk-pixbuf,gdk-pixbuf0 glib,glib12 glibc-solibs,glibcsolibs alsalib,alsa-lib,alsa-lib2* gtk+,gtk+2* gtkdialog,gtkdialog3 alsautils,alsa-utils,alsa-utils2* libungif,libgif,giflib zip,infozip dbus*,libdbus*,libdbus-glib* e3,e3_utf8 hal,libhal* mesa,mesa_*,libgl1-mesa*,mesa-common* libxcb,libxcb_base sane,sane-backends samba,samba-tng,samba_*,mountcifs SDL,libsdl seamonkey*,nss,nspr skype,skype_static udev,udev_*,libudev* util-linux-ng,util-linux,utillinuxng vlc,vlc_nogui,VLC_Plus_Extras xf86-video-ati,xf86-video-ati-* xfdiff,xfdiff-cut xorg_base,xorg_base_t2,x11-common,x-dev,xorg,xorg73_base_t2 acl,libacl* xdg_puppy,xdg-utils perl_tiny,perl-base,perl-modules,perlapi* xorg-util-macros,util-macros'
+PKG_NAME_ALIASES='dirac,schroedinger hunspell,myspell mp,mped mplayer,mplayer_* rxvt-unicode,urxvt,urxvt-unicode cxxlibs,glibc*,libc-* gdk-pixbuf,gdk-pixbuf0 glib,glib12 glibc-solibs,glibcsolibs alsalib,alsa-lib,alsa-lib2* gtk+,gtk+2* gtkdialog,gtkdialog3 alsautils,alsa-utils,alsa-utils2* libungif,libgif,giflib zip,infozip dbus*,libdbus*,libdbus-glib* e3,e3_utf8 hal,libhal* mesa,mesa_*,libgl1-mesa*,mesa-common* libxcb,libxcb_base sane,sane-backends samba,samba-tng,samba_*,mountcifs SDL,libsdl seamonkey*,nss,nspr skype,skype_static udev,udev_*,libudev*,libgudev* util-linux-ng,util-linux,utillinuxng vlc,vlc_nogui,VLC_Plus_Extras xf86-video-ati,xf86-video-ati-* xfdiff,xfdiff-cut xorg_base,xorg_base_t2,x11-common,x-dev,xorg,xorg73_base_t2 acl,libacl* xdg_puppy,xdg-utils perl_tiny,perl-base,perl-modules,perlapi* xorg-util-macros,util-macros'
 
 #w480 some pkgs no longer exist, maybe now builtin to the skeleton f.s. (for ex, 'petget')...
 #this variable is processed in /usr/local/petget/pkg_chooser.sh, used in /usr/local/petget/filterpkgs.sh
 case $DISTRO_COMPAT_VERSION in
  wary5)

Changes to woof-code/rootfs-skeleton/usr/sbin/quicksetup

@@ -47,10 +47,11 @@
 #120714 revert 120708. instead, read BOOT_BOARD to determine type of board booting off. support raspberry pi audio settings.
 #120717 remove XPID=""
 #120901 /usr/share/zoneinfo layout has changed (ubuntu precise).
 #130131 xrandr may have more than one frequency on a line, ex:   1360x768       59.8     60.0
 #130202 130131 not enough. xrandr was not setting chosen vertical frequency.
+#130203 fix insertion of fontsize in xml.
 
 [ "`whoami`" != "root" ] && exec sudo -A ${0} ${@}
 
 export TEXTDOMAIN=quicksetup
 export OUTPUT_CHARSET=UTF-8
@@ -1272,13 +1273,13 @@
    M_y2=$(gettext "<b>Warning</b>
 It is NOT recommended to choose <b>Permanent</b> here, as the default resolution is not really changed, instead it switches resolutions after X has started, which causes a delay and flicker at startup and may have other undesirable side-effects. Instead, run the Video Wizard to choose a permanent resolution.")
    B_permanent=$(gettext 'Permanent')
    B_session=$(gettext 'Session')
    STEP=6	# timeout is x10sec
-   fontsize="x-large" # small, medium, large, x-large
+   fontsize="x-large" # small, medium, large, x-large  130203 fix insertion of fontsize...
    export XY_DIALOG="<window title=\"$WINTITLE\" icon-name=\"gtk-preferences\"><vbox>
-    <text use-markup=\"true\"><label>\"<span size=\"${fontsize}\">${M_y0}</span>\"</label></text>
+    <text use-markup=\"true\"><label>\"<span size='${fontsize}'>${M_y0}</span>\"</label></text>
     <text use-markup=\"true\"><label>\"${M_y1}\"</label></text>
     <text use-markup=\"true\"><label>\"${M_y2}\"</label></text>
 	<progressbar><input>for i in \$(seq 0 10 100); do echo \$i; sleep $STEP; done;echo 100</input>
 	  <label>$(gettext 'Or, it will be canceled in 60 seconds.')</label>
       <action type=\"exit\">TIMEOUT</action></progressbar>

Changes to woof-distro/arm/Packages-puppy-armv7-official

@@ -84,10 +84,12 @@
 squashfs-tools4-4.2-armv7|squashfs-tools4|4.2-armv7||BuildingBlock|200K||squashfs-tools4-4.2-armv7.pet|+linux_kernel&ge2.6.39,+xz,+lzo2|squashfs utilities, with gzip, lzo and xz compression support, use with kernel 2.6.39 or later and with xz support||||
 streamripper-1.64.6-armv7|streamripper|1.64.6-armv7||BuildingBlock|152K||streamripper-1.64.6-armv7.pet|+libmad,+faad2,+libogg,+libvorbis|rip streams||||
 streamripper_DOC-1.64.6-armv7|streamripper_DOC|1.64.6-armv7||BuildingBlock|44K||streamripper_DOC-1.64.6-armv7.pet||rip streams||||
 superscan-0.8-armv7|superscan|0.8-armv7||Network|92K||superscan-0.8-armv7.pet||Superscan network scanner||||
 truncate-1.0-armv7|truncate|1.0-armv7||BuildingBlock|28K||truncate-1.0-armv7.pet||truncate a file, used by pet-tools. note, source is in the pet||||
+udev_167pe-167-patched_t2-extras-armv7|udev_167pe|167-patched_t2-extras-armv7||BuildingBlock|380K||udev_167pe-167-patched_t2-extras-armv7.pet|+gperf,+libxslt|handle kernel uevents, enabled extras, cutdown|ubuntu|lucid||
+udev_167pe_DEV-167-patched_t2-extras-armv7|udev_167pe_DEV|167-patched_t2-extras-armv7||BuildingBlock|52K||udev_167pe_DEV-167-patched_t2-extras-armv7.pet|+udev_167pe|handle kernel uevents|ubuntu|lucid||
 unclutter-1.09-armv7|unclutter|1.09-armv7||BuildingBlock|24K||unclutter-1.09-armv7.pet||hide mouse pointer when not in use||||
 unclutter_DOC-1.09-armv7|unclutter_DOC|1.09-armv7||BuildingBlock|24K||unclutter_DOC-1.09-armv7.pet||hide mouse pointer when not in use||||
 unionfs_utils-0.2.1-armv7|unionfs_utils|0.2.1-armv7||BuildingBlock|64K||unionfs_utils-0.2.1-armv7.pet|+libuuid|utilities for unionfs layered filesystem||||
 unionfs_utils_DOC-0.2.1-armv7|unionfs_utils_DOC|0.2.1-armv7||BuildingBlock|96K||unionfs_utils_DOC-0.2.1-armv7.pet||utilities for unionfs layered filesystem||||
 usb-modeswitch-1.2.1-armv7|usb-modeswitch|1.2.1-armv7||BuildingBlock|136K||usb-modeswitch-1.2.1-armv7.pet|+jimtcl|hybrid usb device mode switcher, note for best results needs woof 20120109+||||

Changes to woof-distro/arm/debian/squeeze/DISTRO_PKGS_SPECS-debian-squeeze

@@ -642,11 +642,12 @@
 yes|texinfo|texinfo|exe>dev,dev,doc,nls
 no|tile||exe
 yes|time|time|exe,dev>null,doc,nls
 yes|truncate||exe,dev,doc,nls
 yes|tslib|libts-0.0-0,libts-bin,libts-dev|exe,dev,doc,nls| #debian lenny: needed by libdirectfb->cairo.
-yes|udev_167||exe,dev,doc,nls
+no|udev_167||exe,dev,doc,nls
+yes|udev_167pe||exe,dev,doc,nls| #has libgudev
 no|udev_libgudev|libgudev-1.0-0,libgudev-1.0-dev|exe,dev,doc,nls
 yes|unclutter|unclutter|exe,dev>null,doc,nls
 yes|unionfs_utils||exe
 yes|unrar|unrar-free|exe,dev,doc,nls
 yes|unzip|unzip|exe,dev>null,doc,nls

Changes to woof-distro/arm/raspbian/wheezy/DISTRO_PKGS_SPECS-raspbian-wheezy

@@ -236,10 +236,11 @@
 yes|gnumeric-plugins-extra|gnumeric-plugins-extra|exe,dev>null,doc,nls
 yes|gnutls|libgnutls26,libgnutls-dev|exe,dev,doc,nls
 yes|goffice|libgoffice-0.8-8,libgoffice-0.8-8-common,libgoffice-0.8-dev|exe,dev,doc,nls
 no|gparted||exe,dev>null,doc,nls
 yes|gparted|gparted|exe,dev>null,doc,nls
+yes|gperf|gperf|exe,dev,doc,nls|
 yes|gphoto2|gphoto2|exe,dev,doc,nls
 yes|gphotofs|gphotofs|exe,dev,doc,nls
 yes|gpptp||exe
 yes|grep|grep|exe,dev>null,doc,nls
 yes|groff|groff|exe>dev,dev,doc,nls
@@ -670,12 +671,12 @@
 no|tile||exe
 yes|time|time|exe,dev>null,doc,nls
 no|transmission||exe,dev,doc,nls| #need to compile this.
 yes|truncate||exe
 yes|tslib|libts-0.0-0,libts-bin,libts-dev|exe,dev,doc,nls
-yes|udev_167||exe
-yes|udev_lib|libudev0,libudev-dev|exe,dev,doc,nls
+no|udev_167||exe
+yes|udev_167pe||exe,dev,doc,nls| #has libgudev
 no|uget||exe
 no|unclutter|unclutter|exe,dev>null,doc,nls
 yes|unclutter||exe,dev>null,doc,nls
 yes|unionfs_utils||exe
 yes|unrar|unrar-free|exe,dev,doc,nls

Changes to woof-distro/arm/ubuntu/precise/DISTRO_PKGS_SPECS-ubuntu-precise

@@ -239,10 +239,11 @@
 yes|gnutls|libgnutls26,libgnutls-dev|exe,dev,doc,nls
 yes|goffice|libgoffice-0.8-8,libgoffice-0.8-8-common,libgoffice-0.8-dev|exe,dev,doc,nls
 yes|gpart|gpart|exe,dev,doc,nls| #useful utility used by gparted.
 no|gparted||exe,dev>null,doc,nls
 yes|gparted|gparted|exe,dev>null,doc,nls
+yes|gperf|gperf|exe,dev,doc,nls|
 yes|gphoto2|gphoto2|exe,dev,doc,nls
 yes|gphotofs|gphotofs|exe,dev,doc,nls
 yes|gpptp||exe
 yes|grep|grep|exe,dev>null,doc,nls
 yes|groff|groff|exe>dev,dev,doc,nls
@@ -675,11 +676,12 @@
 no|tile||exe
 yes|time|time|exe,dev>null,doc,nls
 no|transmission||exe,dev,doc,nls| #need to compile this.
 yes|truncate||exe
 yes|tslib|libts-0.0-0,libts-bin,libts-dev|exe,dev,doc,nls
-yes|udev_167||exe
+no|udev_167||exe
+yes|udev_167pe||exe,dev,doc,nls| #has libgudev
 no|udev_lib|libudev0,libudev-dev|exe,dev,doc,nls
 no|uget||exe
 no|unclutter|unclutter|exe,dev>null,doc,nls
 yes|unclutter||exe,dev>null,doc,nls
 yes|unionfs_utils||exe

Changes to woof-distro/x86/ubuntu/precise/DISTRO_PKGS_SPECS-ubuntu-precise

@@ -260,10 +260,11 @@
 yes|gnutls|libgnutls26,libgnutls-dev|exe,dev,doc,nls
 yes|goffice|libgoffice-0.8-8,libgoffice-0.8-8-common,libgoffice-0.8-dev|exe,dev,doc,nls
 yes|gpart|gpart|exe,dev,doc,nls| #useful utility used by gparted.
 no|gparted||exe,dev>null,doc,nls
 yes|gparted|gparted|exe,dev>null,doc,nls| #/sbin/blkid is necessary for gparted to display information--it is in Lupu_Utilitiesw
+yes|gperf|gperf|exe,dev,doc,nls|
 yes|gphoto2|gphoto2|exe,dev,doc,nls
 yes|gphotofs|gphotofs|exe,dev,doc,nls
 yes|gpptp||exe
 yes|grep|grep|exe,dev>null,doc,nls
 yes|groff|groff|exe>dev,dev,doc,nls
@@ -713,11 +714,12 @@
 yes|tile||exe
 yes|time|time|exe,dev>null,doc,nls
 yes|transmission||exe,dev,doc,nls
 yes|truncate||exe
 yes|tslib|libts-0.0-0,libts-bin,libts-dev|exe,dev,doc,nls
-yes|udev|udev-16*,udev_DEV-16*|exe,dev,doc,nls|pet:wary5
+no|udev|udev-16*,udev_DEV-16*|exe,dev,doc,nls|pet:wary5
+yes|udev_167pe||exe,dev,doc,nls| #configured with libgudev, but pkg very cutdown.
 no|udev|udev,libudev0,libudev-dev|exe,dev,doc,nls
 yes|uget||exe
 yes|unclutter|unclutter|exe,dev>null,doc,nls
 yes|unionfs_utils||exe
 yes|unrar||exe,dev,doc,nls

Changes to woof-distro/x86/ubuntu/precise/Packages-puppy-precise-official

@@ -25,10 +25,12 @@
 service_pack-5.4.2_TO_5.4.2.3_precise|service_pack|5.4.2_TO_5.4.2.3_precise||Setup|1944K||service_pack-5.4.2_TO_5.4.2.3_precise.pet||upgrade package, precise puppy 5.4.2 to 5.4.2.3, fix bugs|ubuntu|precise||
 sylpheed-3.2.0-i686-up|sylpheed|3.2.0-i686-up||Internet;mailnews|1676K||sylpheed-3.2.0-i686-up.pet|+gtk+|E-Mail client|ubuntu|precise||
 sylpheed_DEV-3.2.0-i686-up|sylpheed_DEV|3.2.0-i686-up||Internet;mailnews|3176K||sylpheed_DEV-3.2.0-i686-up.pet|+sylpheed|mail and news client|ubuntu|precise||
 sylpheed_DOC-3.2.0-i686-up|sylpheed_DOC|3.2.0-i686-up||Internet;mailnews|868K||sylpheed_DOC-3.2.0-i686-up.pet||mail and news client||||
 sylpheed_NLS-3.2.0-i686-up|sylpheed_NLS|3.2.0-i686-up||Internet;mailnews|4144K||sylpheed_NLS-3.2.0-i686-up.pet|+sylpheed|mail and news client||||
+udev_167pe-167-patched_t2-extras-precise|udev_167pe|167-patched_t2-extras-precise||BuildingBlock|380K||udev_167pe-167-patched_t2-extras-precise.pet|+gperf,+libxslt|handle kernel uevents, enabled extras|ubuntu|precise||
+udev_167pe_DEV-167-patched_t2-extras-precise|udev_167pe_DEV|167-patched_t2-extras-precise||BuildingBlock|52K||udev_167pe_DEV-167-patched_t2-extras-precise.pet|+udev_167pe|handle kernel uevents|ubuntu|precise||
 xf86-video-nv-2.1.20-i486-up|xf86-video-nv|2.1.20-i486-up||BuildingBlock|224K||xf86-video-nv-2.1.20-i486-up.pet|+xorg|nvidia simple nv xorg driver|ubuntu|precise||
 z_epdfview_fix_precise-20121106|z_epdfview_fix_precise|20121106||BuildingBlock|2416K||z_epdfview_fix_precise-20121106.pet||hack to fix epdfview, was rendering colours wrong. have rolled back to older poppler.|ubuntu|precise||
 z_glib_fix-2.32.3-orig-precise540-i686|z_glib_fix|2.32.3-orig-precise540-i686||System|3956K||z_glib_fix-2.32.3-orig-precise540-i686.pet||Library of useful C routines, original build, fix module loading problem|ubuntu|precise||
 z_glib_fix_DEV-2.32.3-orig-precise540-i686|z_glib_fix_DEV|2.32.3-orig-precise540-i686||System|9620K||z_glib_fix_DEV-2.32.3-orig-precise540-i686.pet||Library of useful C routineds : original build|ubuntu|precise||
 z_mesa-8.0.3-up|z_mesa|8.0.3-up||BuildingBlock|30720K||z_mesa-8.0.3-up.pet||mesa dri, ati r300 has no kms|ubuntu|precise||