Check-in [72799a5530]
Not logged in

Many hyperlinks are disabled.
Use anonymous login to enable hyperlinks.

Overview

SHA1 Hash:72799a5530ffe8393436a964706270657a53a358
Date: 2012-07-29 02:49:13
User: BarryK
Comment:fixed f.s. check at bootup for full install, was failing to unmount main partition

Tags And Properties
Changes

Changes to woof-code/rootfs-skeleton/sbin/initNEW

@@ -13,10 +13,11 @@
 #120627 check ramdisk big enough.
 #120716 revert 120627, /sys not yet loaded. do it a different way. fix for weird 'tr' missing.
 #120716 raspi: no battery-backed hardware clock, so date is wrong, workaround. fixes for rc.sysinit in ramdisk.
 #120717 f.s. maximal mount count reached, perform f.s. check.
 #120718 try force unmount.
+#120729 needed to unmount /old_root/dev, as raspi kernel configured to automount fs on /dev.
 
 INITEXE='/bin/busybox init'
 [ -f /sbin/minit ] && INITEXE='/sbin/minit'
 
 [ -d /initrd ] && exec ${INITEXE} #not a full hd install.
@@ -79,11 +80,11 @@
   ln -snf busybox /mnt/ram0/bin/rdev
   ln -snf busybox /mnt/ram0/bin/sh
   ln -snf busybox /mnt/ram0/bin/mount
   ln -snf busybox /mnt/ram0/bin/umount
   mkdir /mnt/ram0/sbin
-  for ONEBIN in depmod dumpe2fs e2fsck elspci fdisk freeramdisk fsck.ext2 fsck.ext3 fsck.ext4 getty guess_fstype halt hdparm hotplug2stdout hotplug2stdout_notimeout hwclock ifconfig ifplugstatus insmod klogd ldconfig loadkmap losetup lsmod mount.ntfs-3g pivot_root probedisk probedisk2 probepart swapon
+  for ONEBIN in depmod dumpe2fs e2fsck elspci fdisk freeramdisk fsck.ext2 fsck.ext3 fsck.ext4 getty guess_fstype halt hdparm hotplug2stdout hotplug2stdout_notimeout hwclock ifconfig ifplugstatus insmod klogd ldconfig loadkmap losetup lsmod mingetty mount.ntfs-3g pivot_root probedisk probedisk2 probepart swapon
   do
    if [ -e /sbin/$ONEBIN ];then
     cp -a /sbin/$ONEBIN /mnt/ram0/sbin/
    else
     ln -s ../bin/busybox /mnt/ram0/sbin/$ONEBIN
@@ -135,10 +136,11 @@
 if [ \"${HWDATE0}\" != \"\" ];then
  /bin/date -s \"${HWDATE0}\"
 else
  /sbin/hwclock --hctosys --localtime
 fi
+/bin/busybox umount /old_root/dev 2>/dev/null #if kernel configured to mount fs on /dev
 /bin/busybox umount /old_root
 if [ \$? -ne 0 ];then
  echo 'Not so good, was unable to unmount ${PDEV1}. Trying forced unmount...'
  /bin/busybox umount -f /old_root #120718 try force unmount.
  if [ \$? -ne 0 ];then
@@ -155,13 +157,15 @@
  /bin/busybox sync
  echo 'Filesystem check completed!'
 fi
 echo 'The computer now has to be restarted.'
 echo 'Computer will reboot in 4 minutes, else press ENTER for immediate reboot.'
+echo \"(Developers only: press 'c' then ENTER for shell in ramdisk)\"
 echo
 echo -n 'Press ENTER key to reboot:'
 read -t 240 abcdef
+[ \"\$abcdef\" = \"c\" ] && exit #go to shell in ramdisk.
 /bin/busybox umount /proc
 /bin/busybox reboot" > /mnt/ram0/etc/rc.d/rc.sysinit
   chmod 755 /mnt/ram0/etc/rc.d/rc.sysinit
   cp -a /dev /mnt/ram0/
   mkdir /mnt/ram0/lib

Changes to woof-distro/Packages-puppy-noarch-official

@@ -9,17 +9,23 @@
 desk_icon_theme_area042-1|desk_icon_theme_area042|1||Desktop|492K||desk_icon_theme_area042-1.pet|+gtk+|black-white-brown line-art style icons||||
 desk_icon_theme_blue_moon-1|desk_icon_theme_blue_moon|1||Desktop|228K||desk_icon_theme_blue_moon-1.pet||desktop icon set, blue tinge||||
 desk_icon_theme_browndust-1|desk_icon_theme_browndust|1||Desktop|284K||desk_icon_theme_browndust-1.pet||desktop and menu icons||||
 desk_icon_theme_brown_marble-1|desk_icon_theme_brown_marble|1||Desktop|288K||desk_icon_theme_brown_marble-1.pet||desktop icons based on silver marble by steve_s||||
 desk_icon_theme_darkfire-1|desk_icon_theme_darkfire|1||Desktop|316K||desk_icon_theme_darkfire-1.pet||desktop and menu icons||||
+desk_icon_theme_fs-1|desk_icon_theme_fs|1||Desktop|188K||desk_icon_theme_fs-1.pet||desktop and menu icons, violet-orange-silver, put together by jemimah||||
 desk_icon_theme_jq8flat-2|desk_icon_theme_jq8flat|2||Desktop|236K||desk_icon_theme_jq8flat-2.pet||desktop and menu icons, flat grey lines||||
+desk_icon_theme_jungle-1|desk_icon_theme_jungle|1||Desktop|292K||desk_icon_theme_jungle-1.pet||desktop and menu icons, mixed colors, put together by vicmz||||
 desk_icon_theme_lagabluenight-1|desk_icon_theme_lagabluenight|1||Desktop|284K||desk_icon_theme_lagabluenight-1.pet||desktop icon theme, blackish with blue outline||||
 desk_icon_theme_original-1|desk_icon_theme_original|1||Desktop|252K||desk_icon_theme_original-1.pet||desktop and menu icons||||
 desk_icon_theme_silver_marble-1|desk_icon_theme_silver_marble|1||Desktop|304K||desk_icon_theme_silver_marble-1.pet||desktop icons||||
 desk_icon_theme_smooth_color-1|desk_icon_theme_smooth_color|1||Desktop|276K||desk_icon_theme_smooth_color-1.pet||desktop and menu icons||||
 desk_icon_theme_stardust-2|desk_icon_theme_stardust|2||Desktop|292K||desk_icon_theme_stardust-2.pet||desktop and menu icons||||
 desk_icon_theme_stark042-1|desk_icon_theme_stark042|1||Desktop|492K||desk_icon_theme_stark042-1.pet|+gtk+|black-white-orange line-art style icons, based on area042 icons||||
+desk_icon_theme_malays_uniblack-1|desk_icon_theme_malays_uniblack|1||Desktop|264K||desk_icon_theme_malays_uniblack-1.pet||desktop and menu icons, black lines, put together by vicmz||||
+desk_icon_theme_malays_uniblue-1|desk_icon_theme_malays_uniblue|1||Desktop|332K||desk_icon_theme_malays_uniblue-1.pet||desktop and menu icons, pale blue lines, put together by vicmz||||
+desk_icon_theme_neu-1|desk_icon_theme_neu|1||Desktop|172K||desk_icon_theme_neu-1.pet||desktop and menu icons, modern multi-color, put together by jemimah||||
+desk_icon_theme_shining_silver-1|desk_icon_theme_shining_silver|1||Desktop|272K||desk_icon_theme_shining_silver-1.pet||desktop and menu icons, silver-color with blue highlights, put together by vicmz||||
 ffconvert-1.3|ffconvert|1.3||Multimedia|368K||ffconvert-1.3.pet|+ffmpeg|FFConvert multimedia converter||||
 ffconvert_NLS-1.2.1|ffconvert_NLS|1.2.1||Multimedia|304K||ffconvert_NLS-1.2.1.pet|ffconvert|FFConvert multimedia converter||||
 getflash-1.0|getflash|1.0||Internet|52K||getflash-1.0.pet||GetFlash Install Flashplayer||||
 gtk_theme_citrus_cut-1.2|gtk_theme_citrus_cut|1.2||Desktop|172K||gtk_theme_citrus_cut-1.2.pet|+gtk+|gtk2 orangy theme||||
 gtk_theme_delicate_blue-1|gtk_theme_delicate_blue|1||Desktop|48K||gtk_theme_delicate_blue-1.pet|+gtk+|gtk theme, light blue/grey, graduated blue buttons||||
@@ -41,17 +47,16 @@
 jwmconfig2-20111110|jwmconfig2|20111110||Desktop|256K||jwmconfig2-20111110.pet|+jwm2,+gtkdialog3|JWM configuration. note, theme font spec different from shinobars pet. note, designed to work with jwm 500+||||
 jwm_theme_bluevariety-1|jwm_theme_bluevariety|1||Desktop|32K||jwm_theme_bluevariety-1.pet|+jwm2|jwm window manager theme, many shades and gradients of blue||||
 jwm_theme_deepbluebold-1-1|jwm_theme_deepbluebold|1-1||Desktop|36K||jwm_theme_deepbluebold-1-1.pet|+jwm2|Theme for JWM window manager, deep blue, white bold text||||
 jwmthememaker-1.5|jwmthememaker|1.5||Desktop|36K||jwmthememaker-1.5.pet||JWM Theme Maker|ubuntu|lucid||
 jwm_theme_stark-1|jwm_theme_stark|1||Desktop|36K||jwm_theme_stark-1.pet|+jwm2|stark black-white with bits of colour theme for jwm window manager||||
-langpack_de-20120403|langpack_de|20120403||Setup|5457K||langpack_de-20120403.pet||German language-pack for Puppy Linux, for any Puppy built from Woof later than Feb. 28, 2012||||
+langpack_de-20120718|langpack_de|20120718||Setup|1104K||langpack_de-20120718.pet||de language-pack for Puppy Linux, for any Puppy built from Woof later than Feb. 28, 2012||||
 langpack_es-20120527|langpack_es|20120527||Setup|1104K||langpack_es-20120527.pet||Spanish language-pack for Puppy Linux, for any Puppy built from Woof later than Feb. 28, 2012||||
 langpack_fr-20120330|langpack_fr|20120330||Setup|7596K||langpack_fr-20120330.pet||French language-pack for Puppy Linux, for any Puppy built from Woof later than Feb. 27, 2012. Created by esmourguit||||
 langpack_pl-20120403|langpack_pl|20120403||Setup|6412K||langpack_pl-20120403.pet||Polish langpack||||
-langpack_ru-20120403|langpack_ru|20120403||Setup|10000K||langpack_ru-20120403.pet||Russian language-pack for Puppy Linux, for any Puppy built from Woof later than Feb. 28, 2012||||
-langpack_libreoffice_es-20120527-3.5|langpack_libreoffice_es|20120527-3.5||Setup|4520K||langpack_libreoffice_es-20120527-3.5.pet||Spanish language pack for LibreOffice 3.5.x||||
-lhp_sys_info-0.6|lhp_sys_info|0.6||System|156K||lhp_sys_info-0.6.pet||Hardware and Video Reporting Tool, created by tazoc||||
+langpack_ru-20120720|langpack_ru|20120720||Setup|10000K||langpack_ru-20120720.pet||Russian language-pack for Puppy Linux, for any Puppy built from Woof later than Feb. 14, 2012||||
+langpack_libreoffice_es-20120527-3.5|langpack_libreoffice_es|20120527-3.5||Setup|4520K||langpack_libreoffice_es-20120527-3.5.pet||Spanish language pack for LibreOffice 3.5.x||||
 linux_firewall-2.0rc9-patched3|linux_firewall|2.0rc9-patched3||Network|132K||linux_firewall-2.0rc9-patched3.pet||Firewall, with gui install||||
 linux_firmware_dvb-1.20|linux_firmware_dvb|1.20||BuildingBlock|48K||linux_firmware_dvb-1.20.pet||dvb usb kernel firmware||||
 mplayer_codecs_basic-20071007|mplayer_codecs_basic|20071007||Multimedia|612K||mplayer_codecs_basic-20071007.pet||minimum essential codecs||||
 mscw-2|mscw|2||Setup|36K||mscw-2.pet|+alsa-lib,+gtkdialog3|Multiple Sound Card Wizard||||
 net_setup-20111016|net_setup|20111016||Setup|352K||net_setup-20111016.pet|+gtkdialog3|Network Wizard||||
@@ -103,10 +108,11 @@
 shared-mime-info-0.70-6|shared-mime-info|0.70-6||BuildingBlock|272K||shared-mime-info-0.70-6.pet||mime information||||
 shared-mime-info_DEV-0.70-6|shared-mime-info_DEV|0.70-6||BuildingBlock|3772K||shared-mime-info_DEV-0.70-6.pet|+shared-mime-info|mime information||||
 simple_wall_set-0.6-noarch|simple_wall_set|0.6-noarch||Desktop|80K||simple_wall_set-0.6-noarch.pet|+gtkdialog4|SWS simple wallpaper setter||||
 snap2-4.21|snap2|4.21||Utility|152K||snap2-4.21.pet|+rsync|Snap2 snapshot backup||||
 ssh_gui-0.7.1-1-p4|ssh_gui|0.7.1-1-p4||Internet|40K||ssh_gui-0.7.1-1-p4.pet|+gtk+,+openssh_client|secure telnet gui|puppy|4||
+sys-info-0.9|sys-info|0.9||System|148K||sys-info-0.9.pet|+xdriinfo,+xorg|System Information and Video Report, created by TaZoc||||
 usb-modeswitch-data-20111023|usb-modeswitch-data|20111023||BuildingBlock|892K||usb-modeswitch-data-20111023.pet||data for usb-modeswitch pkg||||
 wallpaper-0.6.1-1|wallpaper|0.6.1-1||Desktop|116K||wallpaper-0.6.1-1.pet|+gtkdialog4|Set backdrop image||||
 wcpufreq-0.8|wcpufreq|0.8||System|53K||wcpufreq-0.8.pet||CPU Frequency Scaling Tool||||
 woo-ff-0.1.1|woo-ff|0.1.1||Multimedia|48K||woo-ff-0.1.1.pet|+ffmpeg,+gtkdialog3|woo-ff - multimedia converter||||
 xkbconfigmanager-1.1-1|xkbconfigmanager|1.1-1||Desktop|144K||xkbconfigmanager-1.1-1.pet|+xorg|xorg keyboard manager||||

Changes to woof-distro/arm/Packages-puppy-armv6-official

@@ -45,11 +45,11 @@
 file_DEV-5.03-armv6|file_DEV|5.03-armv6||BuildingBlock|132K||file_DEV-5.03-armv6.pet|+file|file mime handling|debian|squeeze||
 fossil-1.20-20111021125253-armv6|fossil|1.20-20111021125253-armv6||BuildingBlock|1160K||fossil-1.20-20111021125253-armv6.pet||content management system|puppy|||
 fpm2-0.75-armv6|fpm2|0.75-armv6||Personal|208K||fpm2-0.75-armv6.pet|+gtk+|Figaro password manager|puppy|||
 fpm2_DOC-0.75-armv6|fpm2_DOC|0.75-armv6||BuildingBlock|24K||fpm2_DOC-0.75-armv6.pet||figaros password manager||||
 fpm2_NLS-0.75-armv6|fpm2_NLS|0.75-armv6||BuildingBlock|112K||fpm2_NLS-0.75-armv6.pet|+fpm2|figaros password manager||||
-freememapplet_tray-2.4-armv6|freememapplet_tray|2.4-armv6||Desktop|8K||freememapplet_tray-2.4-armv6.pet|+gtk+|display personal-storage free memory in tray|puppy|||
+freememapplet_tray-2.4-sap6|freememapplet_tray|2.4-sap6||Desktop|8K||freememapplet_tray-2.4-sap6.pet|+gtk+|display personal-storage free memory in tray|debian|squeeze||
 fuse-2.8.5-armv6|fuse|2.8.5-armv6||BuildingBlock|276K||fuse-2.8.5-armv6.pet||userspace filesystem interface|puppy|||
 fuse_DEV-2.8.5-armv6|fuse_DEV|2.8.5-armv6||BuildingBlock|820K||fuse_DEV-2.8.5-armv6.pet|+fuse|userspace filesystem interface|puppy|||
 galculator-1.3.4-sap6|galculator|1.3.4-sap6||Business|548K||galculator-1.3.4-sap6.pet||Perform simple and scientific calculations|debian|squeeze||
 galculator_DOC-1.3.4-sap6|galculator_DOC|1.3.4-sap6||Calculate|24K||galculator_DOC-1.3.4-sap6.pet||very nice calculator||||
 galculator_NLS-1.3.4-sap6|galculator_NLS|1.3.4-sap6||Calculate|232K||galculator_NLS-1.3.4-sap6.pet|+galculator|very nice calculator||||
@@ -154,11 +154,11 @@
 mpscan-0.1.0-armv6|mpscan|0.1.0-armv6||BuildingBlock|24K||mpscan-0.1.0-armv6.pet||mpscan utility|debian|squeeze||
 nenscript-1.13.3-armv6|nenscript|1.13.3-armv6||BuildingBlock|36K||nenscript-1.13.3-armv6.pet||Text file to Postscript converter|puppy|||
 nenscript_DOC-1.13.3-armv6|nenscript_DOC|1.13.3-armv6||BuildingBlock|24K||nenscript_DOC-1.13.3-armv6.pet||text file to postscript converter||||
 netpbm-10.34-sap6|netpbm|10.34-sap6||BuildingBlock|728K||netpbm-10.34-sap6.pet|+libxml|Collection of primitive graphics tools converters etc, note later versions have bug|debian|squeeze||
 netpbm_DEV-10.34-sap6|netpbm_DEV|10.34-sap6||BuildingBlock|340K||netpbm_DEV-10.34-sap6.pet|+netpbm|Collection of primitive graphics tools converters etc|debian|squeeze||
-network_tray-2.5-armv6|network_tray|2.5-armv6||Desktop|64K||network_tray-2.5-armv6.pet|+gtk+|network monitor for tray|puppy|||
+network_tray-2.5-sap6|network_tray|2.5-sap6||Desktop|64K||network_tray-2.5-sap6.pet|+gtk+|network monitor for tray|debian|squeeze||
 normalize-0.7.7-armv6|normalize|0.7.7-armv6||BuildingBlock|84K||normalize-0.7.7-armv6.pet|+audiofile,+libmad|An audio file volume normalizer|puppy|||
 normalize_DOC-0.7.7-armv6|normalize_DOC|0.7.7-armv6||BuildingBlock|28K||normalize_DOC-0.7.7-armv6.pet||audio file normalizer||||
 normalize_NLS-0.7.7-armv6|normalize_NLS|0.7.7-armv6||BuildingBlock|56K||normalize_NLS-0.7.7-armv6.pet|+normalize|audio file normalizer||||
 notecase-1.9.8-patched_gcc44_gsv-sap6|notecase|1.9.8-patched_gcc44_gsv-sap6||Personal|1100K||notecase-1.9.8-patched_gcc44_gsv-sap6.pet|+gtk+,+gtksourceview|Notes Manager|debian|squeeze||
 notecase_NLS-1.9.8-patched_gcc44_gsv-sap6|notecase_NLS|1.9.8-patched_gcc44_gsv-sap6||Personal|940K||notecase_NLS-1.9.8-patched_gcc44_gsv-sap6.pet|+notecase|notes manager||||
@@ -183,11 +183,11 @@
 picscale-0.1b-armv6|picscale|0.1b-armv6||BuildingBlock|52K||picscale-0.1b-armv6.pet|+gtk+|cli scale images, used by pPicona, SimpleWALL, created by vovchik|puppy|||
 planner-0.14.5-patched1-sap6|planner|0.14.5-patched1-sap6||Business|1596K||planner-0.14.5-patched1-sap6.pet|+gtk+|Planner Project Management|debian|squeeze||
 planner_DOC-0.14.5-patched1-sap6|planner_DOC|0.14.5-patched1-sap6||Business|3184K||planner_DOC-0.14.5-patched1-sap6.pet||Planner project management||||
 planner_NLS-0.14.5-patched1-sap6|planner_NLS|0.14.5-patched1-sap6||Business|2892K||planner_NLS-0.14.5-patched1-sap6.pet|+planner|Planner project management||||
 pmusic_tray-0.1-armv6|pmusic_tray|0.1-armv6||BuildingBlock|24K||pmusic_tray-0.1-armv6.pet|+pmusic|Pmusic tray app|puppy|||
-powerapplet_tray-2.5-armv6|powerapplet_tray|2.5-armv6||Desktop|24K||powerapplet_tray-2.5-armv6.pet|+gtk+|display battery status in tray|puppy|||
+powerapplet_tray-2.5-sap6|powerapplet_tray|2.5-sap6||Desktop|24K||powerapplet_tray-2.5-sap6.pet|+gtk+|display battery status in tray|debian|squeeze||
 puppyinputdetect-1.1i-armv6|puppyinputdetect|1.1i-armv6||BuildingBlock|7K||puppyinputdetect-1.1i-armv6.pet||detect mouse, keyboard|puppy|||
 puppyphone-1.2-psip-sap6|puppyphone|1.2-psip-sap6||Internet|1576K||puppyphone-1.2-psip-sap6.pet|+gtk+|Psip PuppyPhone Internet telephone|debian|squeeze||
 puppyserialdetect-1.1h-armv6|puppyserialdetect|1.1h-armv6||BuildingBlock|36K||puppyserialdetect-1.1h-armv6.pet||detects mouse, keyboard and modem, created by jesse|puppy|||
 pure-ftpd-1.0.36-armv6|pure-ftpd|1.0.36-armv6||BuildingBlock|260K||pure-ftpd-1.0.36-armv6.pet||ftp program|debian|squeeze||
 pure-ftpd_DOC-1.0.36-armv6|pure-ftpd_DOC|1.0.36-armv6||BuildingBlock|92K||pure-ftpd_DOC-1.0.36-armv6.pet||pure-ftpd documentation||||
@@ -247,10 +247,12 @@
 xdelta-30p-armv6|xdelta|30p-armv6||BuildingBlock|108K||xdelta-30p-armv6.pet||Opensource binary diff deltadifferential compression tools|puppy|||
 xdg_puppy-0.7.6-14-armv6|xdg_puppy|0.7.6-14-armv6||BuildingBlock|328K||xdg_puppy-0.7.6-14-armv6.pet||essential XDG utilities developed by rarsa, -13 has internationalization support|puppy|||
 xdialog-2.3.1-patched20090721-armv6|xdialog|2.3.1-patched20090721-armv6||BuildingBlock|70K||xdialog-2.3.1-patched20090721-armv6.pet|+gtk+|gui frontend for scripts||||
 xdialog_DOC-2.3.1-patched20090721-armv6|xdialog_DOC|2.3.1-patched20090721-armv6||BuildingBlock|696K||xdialog_DOC-2.3.1-patched20090721-armv6.pet||gui for shell scripts||||
 xdialog_NLS-2.3.1-patched20090721-armv6|xdialog_NLS|2.3.1-patched20090721-armv6||BuildingBlock|172K||xdialog_NLS-2.3.1-patched20090721-armv6.pet|+xdialog|gui for shell scripts||||
+xdriinfo-1.0.4-sap6|xdriinfo|1.0.4-sap6||BuildingBlock|20K||xdriinfo-1.0.4-sap6.pet|+xorg,+mesa|query configuration information of X11 DRI drivers, used by sys-info|debian|squeeze||
+xdriinfo_DOC-1.0.4-sap6|xdriinfo_DOC|1.0.4-sap6||BuildingBlock|24K||xdriinfo_DOC-1.0.4-sap6.pet||query configuration information of X11 DRI drivers, used by sys-info||||
 xfdiff-cut-4.5.0-armv6|xfdiff-cut|4.5.0-armv6||Utility|104K||xfdiff-cut-4.5.0-armv6.pet|+gtk+|Xfdiff-cut compare two files|puppy|||
 xfdiff-cut_NLS-4.5.0-armv6|xfdiff-cut_NLS|4.5.0-armv6||Utility|704K||xfdiff-cut_NLS-4.5.0-armv6.pet|+xfdiff-cut|compare two files||||
 xload-1.1.0-armv6|xload|1.1.0-armv6||BuildingBlock|44K||xload-1.1.0-armv6.pet|+xorg|plot cpu load|puppy|||
 xlockmore-5.31-patched-sap6|xlockmore|5.31-patched-sap6||BuildingBlock|212K||xlockmore-5.31-patched-sap6.pet|+xorg_base|screen lock and screensaver|debian|squeeze||
 xlockmore_DOC-5.31-patched-sap6|xlockmore_DOC|5.31-patched-sap6||BuildingBlock|84K||xlockmore_DOC-5.31-patched-sap6.pet||screen lock||||

Changes to woof-distro/arm/debian/squeeze/DISTRO_PKGS_SPECS-debian-squeeze

@@ -236,11 +236,12 @@
 no|gtksourceview||exe,dev,doc,nls| #my pet with genie.lang added... no, now in template.
 yes|gtksourceview|libgtksourceview2.0-0,libgtksourceview2.0-common,libgtksourceview2.0-dev|exe,dev,doc,nls
 yes|gtkspell|libgtkspell0,libgtkspell-dev|exe,dev,doc,nls
 no|gtrayicon||exe
 yes|guess_fs||exe,dev,doc,nls
-yes|gutenprint|cups-driver-gutenprint,libgutenprint2,libgutenprint-dev,libgutenprintui2-1,libgutenprintui2-dev|exe,dev,doc,nls
+no|gutenprint|cups-driver-gutenprint,libgutenprint2,libgutenprint-dev,libgutenprintui2-1,libgutenprintui2-dev|exe,dev,doc,nls
+yes|gutenprint||exe,dev,doc,nls| #compiled in sap6 by 01micko.
 no|gview||exe
 yes|gwhere|gwhere|exe,dev,doc,nls
 no|gxine|gxine,gxineplugin|exe,dev>null,doc,nls
 yes|gzip|gzip|exe,dev>null,doc,nls
 yes|hal|hal,libhal1,libhal-dev,libhal-storage1,libhal-storage-dev|exe,dev,doc,nls|
@@ -282,11 +283,10 @@
 no|lame|lame,libmp3lame0,libmp3lame-dev|exe,dev,doc,nls
 no|lame||exe,dev,doc,nls
 yes|lcms|liblcms1,liblcms1-dev,liblcms-utils|exe,dev,doc,nls
 yes|leafpad||exe,dev>null,doc,nls
 yes|less|less|exe,dev>null,doc,nls
-yes|lhp_sys_info||exe,dev,doc,nls
 yes|libao|libao4,libao-dev|exe,dev,doc,nls
 yes|libart|libart-2.0-2,libart-2.0-dev|exe,dev,doc,nls
 yes|libasyncns|libasyncns0,libasyncns-dev|exe,dev,doc,nls
 yes|libavc1394|libavc1394-0,libavc1394-dev|exe,dev,doc,nls
 yes|libbonobo|libbonobo2-0,libbonobo2-dev,libbonoboui2-0,libbonoboui2-dev|exe,dev,doc,nls
@@ -618,10 +618,11 @@
 yes|superscan||exe
 yes|sylpheed|sylpheed,libcompfaceg1,libgpgme11,libldap-2.4-2,libonig2,libpisock9,libbluetooth3|exe,dev,doc,nls
 no|sylpheed||exe
 no|sys-freedos||exe
 yes|sysfsutils|libsysfs2,libsysfs-dev,sysfsutils|exe,dev,doc,nls
+yes|sys-info||exe,dev,doc,nls
 yes|syslinux|syslinux-common|exe,dev>null,doc,nls| #no, must use pet syslinux pkg.
 no|syslinux||exe
 no|sysprof|sysprof|exe>dev,dev,doc,nls| #no ARMEL deb
 yes|sysvinit-utils-cut|sysvinit,sysvinit-utils|exe,dev,doc,nls
 no|taglib|libtag1c2a,libtag1-vanilla,libtag1-dev,libtagc0,libtagc0-dev|exe,dev,doc,nls
@@ -671,10 +672,11 @@
 yes|xclip||exe,dev,doc,nls
 yes|xcur2png||exe,dev,doc,nls
 yes|xdelta||exe,dev,doc,nls
 yes|xdg_puppy||exe,dev,doc,nls
 yes|xdialog||exe,dev,doc,nls
+yes|xdriinfo||exe,dev,doc,nls| #needed by sys-info.
 no|xfce4-battery-plugin|xfce4-battery-plugin|exe,dev,doc,nls
 no|xfce4-clipman-plugin|xfce4-clipman-plugin|exe,dev,doc,nls
 no|xfce4-cpugraph-plugin|xfce4-cpugraph-plugin|exe,dev,doc,nls
 no|xfce4-fsguard-plugin|xfce4-fsguard-plugin|exe,dev,doc,nls
 no|xfce4-genmon-plugin|xfce4-genmon-plugin|exe,dev,doc,nls

Changes to woof-distro/arm/debian/squeeze/DISTRO_SPECS

@@ -1,9 +1,9 @@
 #One or more words that identify this distribution:
 DISTRO_NAME='Squeezed Arm Puppy'
 #version number of this distribution:
-DISTRO_VERSION=5.105
+DISTRO_VERSION=5.112
 #The distro whose binary packages were used to build this distribution:
 DISTRO_BINARY_COMPAT='debian'
 #Prefix for some filenames: exs: sqzdsave.2fs, sqzd-4.99.0.sfs
 DISTRO_FILE_PREFIX='sap6'
 #The version of the distro whose binary packages were used to build this distro:

Changes to woof-distro/arm/debian/squeeze/Packages-puppy-squeeze-official

@@ -1,1 +1,4 @@
 0hack1_dev-2-woof|0hack1_dev|2-woof||BuildingBlock|164K||0hack1_dev-2-woof.pet||hack for debian|debian|squeeze||
+gutenprint-5.2.8-sap6|gutenprint|5.2.8-sap6||BuildingBlock|11316K||gutenprint-5.2.8-sap6.pet|+libkrb5,+libkrb5support0|printer drivers|debian|squeeze||
+gutenprint_DEV-5.2.8-sap6|gutenprint_DEV|5.2.8-sap6||BuildingBlock|2256K||gutenprint_DEV-5.2.8-sap6.pet|+gutenprint|gutenprint headers|debian|squeeze||
+gutenprint_NLS-5.2.8-sap6|gutenprint_NLS|5.2.8-sap6||BuildingBlock|10428K||gutenprint_NLS-5.2.8-sap6.pet||gutenprint locales||||

Changes to woof-distro/arm/gentoo/gap6/DISTRO_PKGS_SPECS-gentoo-gap6

@@ -542,10 +542,11 @@
 no|sweep|sweep|exe,dev,doc,nls
 no|sylpheed||exe
 no|synclient||exe
 no|sys-freedos||exe
 no|sysfsutils|sysfsutils|exe,dev,doc,nls
+yes|sys-info||exe,dev,doc,nls
 no|syslinux|syslinux|exe,dev>null,doc,nls| #must use my pet syslinux pkg..
 no|syslinux||exe
 no|sysprof||exe>dev,dev,doc,nls
 yes|sysvinit-utils-cut|sysvinit|exe,dev,doc,nls|
 no|tar|tar|exe,dev>null,doc,nls| #slackware tar 1.23 slightly broken, use my pet 1.22... no using 1.26
@@ -598,10 +599,11 @@
 no|xcompmgr||exe
 yes|xcur2png||exe,dev,doc,nls
 yes|xdelta||exe,dev,doc,nls
 yes|xdg_puppy||exe,dev,doc,nls
 yes|xdialog||exe,dev,doc,nls
+yes|xdriinfo||exe,dev,doc,nls| #needed by sys-info.
 yes|xfdiff-cut||exe,dev,doc,nls
 no|xfprot||exe
 no|xine-lib|xine-lib|exe,dev,doc,nls
 no|xine-lib||exe,dev,doc,nls
 yes|xkbconfigmanager||exe

Changes to woof-distro/arm/raspbian/wheezy/DISTRO_PKGS_SPECS-raspbian-wheezy

@@ -311,11 +311,10 @@
 yes|lcms|liblcms1,liblcms1-dev,liblcms-utils|exe,dev,doc,nls
 yes|lcms2|liblcms2-2,liblcms2-dev,liblcms2-utils|exe,dev,doc,nls
 no|leafpad|leafpad|exe,dev>null,doc,nls
 yes|leafpad||exe,dev>null,doc,nls
 yes|less|less|exe,dev>null,doc,nls
-yes|lhp_sys_info||exe
 yes|libaacs|libaacs0,libaacs-dev|exe,dev,doc,nls| #mplayer needs this.
 yes|libao|libao4,libao-common,libao-dev|exe,dev,doc,nls
 yes|libarchive|libarchive12|exe,dev,doc,nls| #needed by cmake.
 yes|libart|libart-2.0-2,libart-2.0-dev|exe,dev,doc,nls
 yes|libasyncns|libasyncns0,libasyncns-dev|exe,dev,doc,nls| #needed by mplayer.
@@ -648,10 +647,11 @@
 no|sylpheed|sylpheed,libbluetooth3,libcompfaceg1,libonig2,libpisock9,libgpgme11|exe,dev,doc,nls
 no|sylpheed||exe
 no|synclient||exe
 no|sys-freedos||exe
 yes|sysfsutils|libsysfs2,libsysfs-dev,sysfsutils|exe,dev,doc,nls
+yes|sys-info||exe,dev,doc,nls
 no|syslinux|syslinux|exe,dev>null,doc,nls
 no|syslinux||exe| #maybe x86 only. see alternatives in en.wikipedia.org/wiki/Comparison_of_boot_loaders
 no|sysprof|sysprof|exe>dev,dev,doc,nls
 no|sysvinit||exe| #ONLY NEED ONE EXECUTABLE (last), it is in in ubuntu sysvinit-utils.###
 yes|sysvinit-utils-cut|sysvinit-utils|exe,dev,doc,nls| #only want one executable (last).
@@ -700,11 +700,12 @@
 yes|xarchive||exe,dev,doc,nls
 yes|xclip|xclip|exe,dev,doc,nls
 yes|xcur2png||exe
 yes|xdelta||exe
 yes|xdg_puppy||exe
-yes|xdialog||exe
+yes|xdialog||exe,dev,doc,nls
+yes|xdriinfo||exe,dev,doc,nls| #needed by sys-info.
 no|xemeraldia||exe
 no|xf86-video-intel||exe,dev,doc,nls
 no|xfce4-battery-plugin|xfce4-battery-plugin|exe,dev,doc,nls
 no|xfce4-clipman-plugin|xfce4-clipman-plugin|exe,dev,doc,nls
 no|xfce4-cpugraph-plugin|xfce4-cpugraph-plugin|exe,dev,doc,nls

Changes to woof-distro/arm/ubuntu/precise/DISTRO_PKGS_SPECS-ubuntu-precise

@@ -306,11 +306,10 @@
 yes|lcms|liblcms1,liblcms1-dev,liblcms-utils|exe,dev,doc,nls
 yes|lcms2|liblcms2-2,liblcms2-dev,liblcms2-utils|exe,dev,doc,nls
 no|leafpad|leafpad|exe,dev>null,doc,nls
 yes|leafpad||exe,dev>null,doc,nls
 yes|less|less|exe,dev>null,doc,nls
-yes|lhp_sys_info||exe
 yes|libaacs|libaacs0,libaacs-dev|exe,dev,doc,nls| #mplayer needs this.
 yes|libao|libao4,libao-common,libao-dev|exe,dev,doc,nls
 yes|libarchive|libarchive12|exe,dev,doc,nls| #needed by cmake.
 yes|libart|libart-2.0-2,libart-2.0-dev|exe,dev,doc,nls
 yes|libasyncns|libasyncns0,libasyncns-dev|exe,dev,doc,nls| #needed by mplayer.
@@ -639,10 +638,11 @@
 no|sylpheed|sylpheed,libbluetooth3,libcompfaceg1,libonig2,libpisock9,libgpgme11|exe,dev,doc,nls
 no|sylpheed||exe
 no|synclient||exe
 no|sys-freedos||exe
 yes|sysfsutils|libsysfs2,libsysfs-dev,sysfsutils|exe,dev,doc,nls
+yes|sys-info||exe,dev,doc,nls
 no|syslinux|syslinux|exe,dev>null,doc,nls
 no|syslinux||exe| #maybe x86 only. see alternatives in en.wikipedia.org/wiki/Comparison_of_boot_loaders
 no|sysprof|sysprof|exe>dev,dev,doc,nls
 no|sysvinit||exe| #ONLY NEED ONE EXECUTABLE (last), it is in in ubuntu sysvinit-utils.###
 yes|sysvinit-utils-cut|sysvinit-utils|exe,dev,doc,nls| #only want one executable (last).
@@ -691,11 +691,12 @@
 yes|xarchive||exe,dev,doc,nls
 yes|xclip|xclip|exe,dev,doc,nls
 yes|xcur2png||exe
 yes|xdelta||exe
 yes|xdg_puppy||exe
-yes|xdialog||exe
+yes|xdialog||exe,dev,doc,nls
+yes|xdriinfo||exe,dev,doc,nls| #needed by sys-info.
 no|xemeraldia||exe
 no|xf86-video-intel||exe,dev,doc,nls
 no|xfce4-battery-plugin|xfce4-battery-plugin|exe,dev,doc,nls
 no|xfce4-clipman-plugin|xfce4-clipman-plugin|exe,dev,doc,nls
 no|xfce4-cpugraph-plugin|xfce4-cpugraph-plugin|exe,dev,doc,nls

Changes to woof-distro/x86/Packages-puppy-common-official

@@ -373,10 +373,12 @@
 xclip-0.10|xclip|0.10||BuildingBlock|60K||xclip-0.10.pet||copy/paste x-selection and clipboard from script|puppy|4||
 xcur2png-0.7.0-p4|xcur2png|0.7.0-p4||BuildingBlock|28K||xcur2png-0.7.0-p4.pet||converter cursor image to png|puppy|4||
 xdelta-30p-w5|xdelta|30p-w5||BuildingBlock|108K||xdelta-30p-w5.pet||Opensource binary diff deltadifferential compression tools|puppy|wary5||
 xdg_puppy-0.7.6-14-p4|xdg_puppy|0.7.6-14-p4||BuildingBlock|328K||xdg_puppy-0.7.6-14-p4.pet||essential XDG utilities developed by rarsa, -13 has internationalization support|puppy|4||
 xdialog-2.3.1.pup2|xdialog|2.3.1.pup2||BuildingBlock|70K||xdialog-2.3.1.pup2.pet|+gtk+|gui frontend for scripts|puppy|||
+xdriinfo-1.0.4-x86|xdriinfo|1.0.4-x86||BuildingBlock|20K||xdriinfo-1.0.4-x86.pet|+xorg,+mesa|query configuration information of X11 DRI drivers, used by sys-info|puppy|||
+xdriinfo_DOC-1.0.4-x86|xdriinfo_DOC|1.0.4-x86||BuildingBlock|24K||xdriinfo_DOC-1.0.4-x86.pet||query configuration information of X11 DRI drivers, used by sys-info||||
 xlock_gui-0.2-4|xlock_gui|0.2-4||Desktop|60K||xlock_gui-0.2-4.pet|+xlockmore|screen lock and screensaver||||
 xlockmore-5.31-w1|xlockmore|5.31-w1||BuildingBlock|212K||xlockmore-5.31-w1.pet|+xorg_base|screen lock and screensaver|t2|8.0rc||
 xz-4.999.9beta-124-gb637-q1|xz|4.999.9beta-124-gb637-q1||BuildingBlock|280K|pet_packages-quirky|xz-4.999.9beta-124-gb637-q1.pet||file compression/decompression utilities|t2|8.0rc|official|
 xz_DEV-4.999.9beta-124-gb637-q1|xz_DEV|4.999.9beta-124-gb637-q1||BuildingBlock|968K|pet_packages-quirky|xz_DEV-4.999.9beta-124-gb637-q1.pet|+xz|file compression/decompression library|t2|8.0rc|official|
 yad-0.12.4-w5|yad|0.12.4-w5||BuildingBlock|120K||yad-0.12.4-w5.pet|+gtk+|gui frontend for shell scripts|puppy|wary5||

Changes to woof-distro/x86/arch/rolling-release/DISTRO_PKGS_SPECS-arch

@@ -473,11 +473,11 @@
 yes|subversion|subversion|exe>dev,dev,doc,nls
 yes|superscan||exe
 yes|sylpheed||exe
 yes|sys-freedos||exe
 yes|sysfsutils|sysfsutils|exe,dev,doc,nls
-#must use pet syslinux pkg...
+yes|sys-info||exe,dev,doc,nls
 no|syslinux|syslinux|exe,dev>null,doc,nls
 yes|syslinux||exe
 yes|sysprof||exe>dev,dev,doc,nls
 yes|sysvinit||exe
 yes|tar|tar|exe,dev>null,doc,nls
@@ -517,11 +517,12 @@
 yes|xcb-util|xcb-util|exe,dev,doc,nls
 yes|xclip||exe
 yes|xcur2png||exe
 yes|xdelta||exe
 yes|xdg_puppy||exe
-yes|xdialog||exe
+yes|xdialog||exe,dev,doc,nls
+yes|xdriinfo||exe,dev,doc,nls| #needed by sys-info.
 yes|xfdiff-cut||exe
 yes|xfprot||exe
 no|xine-lib|xine-lib|exe,dev,doc,nls
 yes|xine-lib||exe,dev,doc,nls
 yes|xkbconfigmanager||exe

Changes to woof-distro/x86/debian/squeeze/DISTRO_PKGS_SPECS-debian-squeeze

@@ -274,11 +274,10 @@
 no|lame|lame,libmp3lame0,libmp3lame-dev|exe,dev,doc,nls
 yes|lame||exe,dev,doc,nls
 yes|lcms|liblcms1,liblcms1-dev,liblcms-utils|exe,dev,doc,nls
 no|leafpad|leafpad|exe,dev>null,doc,nls
 yes|less|less|exe,dev>null,doc,nls
-yes|lhp_sys_info||exe
 yes|libao|libao4,libao-dev|exe,dev,doc,nls
 yes|libart|libart-2.0-2,libart-2.0-dev|exe,dev,doc,nls
 yes|libasyncns|libasyncns0,libasyncns-dev|exe,dev,doc,nls
 yes|libavc1394|libavc1394-0,libavc1394-dev|exe,dev,doc,nls
 yes|libbonobo|libbonobo2-0,libbonobo2-dev,libbonoboui2-0,libbonoboui2-dev|exe,dev,doc,nls
@@ -602,10 +601,11 @@
 yes|subversion|subversion,libsvn1,libdb4.6,libneon27-gnutls,libaprutil1,libpq5,libmysqlclient16,libapr1|exe>dev,dev,doc,nls
 yes|superscan||exe
 no|sylpheed||exe
 yes|sys-freedos||exe
 yes|sysfsutils|libsysfs2,libsysfs-dev,sysfsutils|exe,dev,doc,nls
+yes|sys-info||exe,dev,doc,nls
 no|syslinux|syslinux|exe,dev>null,doc,nls| #no, must use pet syslinux pkg.
 yes|syslinux||exe
 yes|sysprof|sysprof|exe>dev,dev,doc,nls
 yes|sysvinit||exe
 yes|taglib|libtag1c2a,libtag1-vanilla,libtag1-dev,libtagc0,libtagc0-dev|exe,dev,doc,nls
@@ -653,11 +653,12 @@
 yes|xarchive||exe,dev>null,doc,nls
 yes|xclip||exe
 yes|xcur2png||exe
 yes|xdelta||exe
 yes|xdg_puppy||exe
-yes|xdialog||exe
+yes|xdialog||exe,dev,doc,nls
+yes|xdriinfo||exe,dev,doc,nls| #needed by sys-info.
 no|xfce4-battery-plugin|xfce4-battery-plugin|exe,dev,doc,nls
 no|xfce4-clipman-plugin|xfce4-clipman-plugin|exe,dev,doc,nls
 no|xfce4-cpugraph-plugin|xfce4-cpugraph-plugin|exe,dev,doc,nls
 no|xfce4-fsguard-plugin|xfce4-fsguard-plugin|exe,dev,doc,nls
 no|xfce4-genmon-plugin|xfce4-genmon-plugin|exe,dev,doc,nls

Changes to woof-distro/x86/mageia/cauldron/DISTRO_PKGS_SPECS-mageia-cauldron

@@ -253,11 +253,10 @@
 yes|krb5|krb5,libkrb53,libkrb53-devel|exe,dev,doc,nls|
 yes|lame|lame,liblame0,liblame-devel|exe,dev,doc,nls| #tainted
 yes|lcms|lcms,liblcms1,liblcms-devel|exe,dev,doc,nls|
 no|leafpad|leafpad|exe,dev>null,doc,nls| #we are using nicoedit.
 yes|less|less|exe,dev>null,doc,nls|
-yes|lhp_sys_info||exe
 yes|libaa|libaa1,libaa-devel|exe,dev,doc,nls| #needed by gphoto2
 yes|libao|libao4,libao-devel|exe,dev,doc,nls|
 yes|libarchive|libarchive12,libarchive-devel|exe,dev,doc,nls|
 yes|libart|libart_lgpl2,libart_lgpl-devel|exe,dev,doc,nls|
 yes|libasyncns|libasyncns0,libasyncns-devel|exe,dev,doc,nls|
@@ -588,10 +587,11 @@
 yes|superscan||exe|
 no|sylpheed|sylpheed|exe,dev,doc,nls| #too many deps.
 no|sylpheed||exe,dev,doc,nls|
 yes|sys-freedos||exe|
 yes|sysfsutils|sysfsutils,libsysfs2,libsysfs-devel|exe,dev,doc,nls|
+yes|sys-info||exe,dev,doc,nls
 yes|syslinux||exe,dev,doc,nls| #must use my pet.
 yes|sysprof||exe>dev,dev,doc,nls| #no mageia pkg.
 yes|sysvinit||exe| #my cutdown pet.
 yes|t1lib|t1lib-config,t1lib-progs,libt1lib5,libt1lib-devel|exe,dev,doc,nls| #needed by abiword mathview plugin
 yes|tar|tar|exe,dev>null,doc,nls|
@@ -635,11 +635,12 @@
 yes|xarchive||exe,dev>null,doc,nls|
 yes|xclip||exe|
 yes|xcur2png||exe|
 yes|xdelta||exe|
 yes|xdg_puppy||exe|
-yes|xdialog||exe|
+yes|xdialog||exe,dev,doc,nls|
+yes|xdriinfo||exe,dev,doc,nls| #needed by sys-info.
 yes|xfdiff-cut||exe|
 yes|xfprot||exe|
 yes|xkbconfigmanager||exe|
 yes|xlock_gui||exe|
 yes|xlockmore||exe| #cutdown pet.

Changes to woof-distro/x86/pet-based/racy/DISTRO_PKGS_SPECS-puppy-wary5

@@ -315,11 +315,10 @@
 no|lame||exe,dev,doc,nls
 no|lamesmbxplorer||exe
 yes|lcms|lcms|exe,dev,doc,nls
 yes|leafpad|leafpad|exe,dev>null,doc,nls
 no|less|less|exe,dev>null,doc,nls
-yes|lhp_sys_info||exe
 yes|libao|libao|exe,dev,doc,nls
 yes|libart|libart|exe,dev,doc,nls
 yes|libcap|libcap|exe,dev,doc,nls
 yes|libcddb|libcddb|exe,dev,doc,nls
 yes|libcdio|libcdio|exe,dev,doc,nls
@@ -637,11 +636,11 @@
 no|swfdec_cut||exe,dev,doc,nls
 no|swfdec-mozilla||exe
 no|sylpheed|sylpheed|exe,dev,doc,nls
 yes|sys-freedos||exe
 yes|sysfsutils|sysfsutils|exe,dev,doc,nls
-#must use pet syslinux pkg...
+yes|sys-info||exe,dev,doc,nls
 no|syslinux|syslinux|exe,dev>null,doc,nls
 yes|syslinux||exe
 yes|sysprof|sysprof|exe>dev,dev,doc,nls
 yes|sysvinit||exe
 yes|tar|tar|exe,dev>null,doc,nls
@@ -701,10 +700,11 @@
 no|xdelta||exe
 yes|xdelta|xdelta|exe,dev,doc,nls
 yes|xdg_puppy||exe
 no|xdialog|xdialog|exe,dev,doc,nls
 yes|xdialog|xdialog-2.3.1-patched_amigo*|exe,dev,doc,nls| #see forum t=64795
+yes|xdriinfo||exe,dev,doc,nls| #needed by sys-info.
 no|xf86-input-synaptics|xf86-input-synaptics|exe,dev,doc,nls| #WARY
 no|xf86-video-i810_old|xf86-video-i810_old|exe,dev,doc,nls| #WARY i compiled the i810_drv.so driver from Xorg 7.2 in Xorg 7.3.
 no|xf86-video-openchrome|xf86-video-openchrome|exe,dev,doc,nls| #WARY
 no|xf86-video-vesa|xf86-video-vesa-1.3*,xf86-video-vesa_DEV-1.3*|exe,dev,doc,nls| #have this in xserver_xorg_partialcut_t2. note, do not use v2.3.0 with xorg 7.3.
 yes|xfdiff-cut||exe

Changes to woof-distro/x86/pet-based/wary/DISTRO_PKGS_SPECS-puppy-wary5

@@ -314,11 +314,10 @@
 no|lame||exe,dev,doc,nls
 no|lamesmbxplorer||exe
 yes|lcms|lcms|exe,dev,doc,nls
 yes|leafpad|leafpad|exe,dev>null,doc,nls
 no|less|less|exe,dev>null,doc,nls
-yes|lhp_sys_info||exe
 yes|libao|libao|exe,dev,doc,nls
 yes|libart|libart|exe,dev,doc,nls
 yes|libcap|libcap|exe,dev,doc,nls
 yes|libcddb|libcddb|exe,dev,doc,nls
 yes|libcdio|libcdio|exe,dev,doc,nls
@@ -636,11 +635,11 @@
 no|swfdec_cut||exe,dev,doc,nls
 no|swfdec-mozilla||exe
 no|sylpheed|sylpheed|exe,dev,doc,nls
 yes|sys-freedos||exe
 yes|sysfsutils|sysfsutils|exe,dev,doc,nls
-#must use pet syslinux pkg...
+yes|sys-info||exe,dev,doc,nls
 no|syslinux|syslinux|exe,dev>null,doc,nls
 yes|syslinux||exe
 yes|sysprof|sysprof|exe>dev,dev,doc,nls
 yes|sysvinit||exe
 yes|tar|tar|exe,dev>null,doc,nls
@@ -700,10 +699,11 @@
 no|xdelta||exe
 yes|xdelta|xdelta|exe,dev,doc,nls
 yes|xdg_puppy||exe
 no|xdialog|xdialog|exe,dev,doc,nls
 yes|xdialog|xdialog-2.3.1-patched_amigo*|exe,dev,doc,nls| #see forum t=64795
+yes|xdriinfo||exe,dev,doc,nls| #needed by sys-info.
 yes|xf86-input-synaptics|xf86-input-synaptics|exe,dev,doc,nls| #WARY
 yes|xf86-video-i810_old|xf86-video-i810_old|exe,dev,doc,nls| #WARY i compiled the i810_drv.so driver from Xorg 7.2 in Xorg 7.3.
 yes|xf86-video-openchrome|xf86-video-openchrome|exe,dev,doc,nls| #WARY
 no|xf86-video-vesa|xf86-video-vesa-1.3*,xf86-video-vesa_DEV-1.3*|exe,dev,doc,nls| #have this in xserver_xorg_partialcut_t2. note, do not use v2.3.0 with xorg 7.3.
 yes|xfdiff-cut||exe

Changes to woof-distro/x86/slackware/13.37/DISTRO_PKGS_SPECS-slackware-13.37

@@ -617,10 +617,11 @@
 no|swfdec-mozilla||exe
 no|sylpheed||exe
 yes|synclient||exe
 yes|sys-freedos||exe
 yes|sysfsutils|sysfsutils|exe,dev,doc,nls
+yes|sys-info||exe,dev,doc,nls
 no|syslinux|syslinux|exe,dev>null,doc,nls| #must use my pet syslinux pkg..
 yes|syslinux||exe
 yes|sysprof||exe>dev,dev,doc,nls
 yes|sysvinit||exe
 yes|tar|tar|exe,dev>null,doc,nls| #slackware tar 1.23 slightly broken, use my pet 1.22... no using 1.26
@@ -679,11 +680,12 @@
 no|xcompmgr|xcompmgr|exe,dev,doc,nls
 yes|xcompmgr||exe
 yes|xcur2png||exe
 yes|xdelta||exe
 yes|xdg_puppy||exe
-yes|xdialog||exe
+yes|xdialog||exe,dev,doc,nls
+yes|xdriinfo||exe,dev,doc,nls| #needed by sys-info.
 no|xf86-video-nouveau||exe,dev,doc,nls
 yes|xf86-input-synaptics||exe,dev,doc,nls
 no|xf86-video-intel||exe
 no|xf86-video-rdc||exe,dev,doc,nls
 yes|xfdiff-cut||exe

Changes to woof-distro/x86/ubuntu/precise/DISTRO_PKGS_SPECS-ubuntu-precise

@@ -310,11 +310,10 @@
 yes|lame|lame,libmp3lame0,libmp3lame-dev|exe,dev,doc,nls
 yes|lcms|liblcms1,liblcms1-dev,liblcms-utils|exe,dev,doc,nls
 yes|lcms2|liblcms2-2,liblcms2-dev,liblcms2-utils|exe,dev,doc,nls
 yes|leafpad|leafpad|exe,dev>null,doc,nls
 yes|less|less|exe,dev>null,doc,nls
-yes|lhp_sys_info||exe
 yes|libaacs|libaacs0,libaacs-dev|exe,dev,doc,nls| #mplayer needs this.
 yes|libao|libao4,libao-common,libao-dev|exe,dev,doc,nls
 yes|libarchive|libarchive12|exe,dev,doc,nls| #needed by cmake.
 yes|libart|libart-2.0-2,libart-2.0-dev|exe,dev,doc,nls
 yes|libasyncns|libasyncns0,libasyncns-dev|exe,dev,doc,nls| #needed by mplayer.
@@ -635,10 +634,11 @@
 no|sylpheed|sylpheed,libbluetooth3,libcompfaceg1,libonig2,libpisock9,libgpgme11|exe,dev,doc,nls
 no|sylpheed||exe
 yes|synclient||exe
 yes|sys-freedos||exe
 yes|sysfsutils|libsysfs2,libsysfs-dev,sysfsutils|exe,dev,doc,nls
+yes|sys-info||exe,dev,doc,nls
 no|syslinux|syslinux|exe,dev>null,doc,nls
 yes|syslinux||exe,dev,doc,nls| #must use pet syslinux pkg.
 yes|sysprof|sysprof|exe>dev,dev,doc,nls
 yes|sysvinit||exe
 yes|tar|tar|exe,dev>null,doc,nls
@@ -684,11 +684,12 @@
 yes|xarchive||exe
 yes|xclip||exe
 yes|xcur2png||exe
 yes|xdelta||exe
 yes|xdg_puppy||exe
-yes|xdialog||exe
+yes|xdialog||exe,dev,doc,nls
+yes|xdriinfo||exe,dev,doc,nls| #needed by sys-info.
 yes|xemeraldia||exe
 no|xfce4-battery-plugin|xfce4-battery-plugin|exe,dev,doc,nls
 no|xfce4-clipman-plugin|xfce4-clipman-plugin|exe,dev,doc,nls
 no|xfce4-cpugraph-plugin|xfce4-cpugraph-plugin|exe,dev,doc,nls
 no|xfce4-fsguard-plugin|xfce4-fsguard-plugin|exe,dev,doc,nls