Check-in [e737c34dd0]
Not logged in

Many hyperlinks are disabled.
Use anonymous login to enable hyperlinks.

Overview

SHA1 Hash:e737c34dd0df571611d072b53039707fd55a6a2a
Date: 2012-05-14 23:53:05
User: BarryK
Comment:improvements for (Ubuntu) Precise, (Mageia) Drake pups

Tags And Properties
Changes

Changes to woof-code/packages-templates/glib/usr/lib/PLUSEXTRADIRS


Deleted woof-code/packages-templates/glib/usr/lib/gio/PLUSEXTRADIRS

Changes to woof-code/rootfs-skeleton/usr/sbin/pupdial

@@ -192,12 +192,12 @@
   DEVM="`echo -n "$MYDEVM" | cut -f 3,4 -d '/'`"
   [ $RETVAL -eq 0 ] && modemtest $DEVM initonly
  fi
 fi
 
-#v413 Assure user...
-yaf-splash -close never -bg orange -text "$(gettext 'Reading modem configuration file...')" &
+#v413 Assure user... 120514 bigger font...
+yaf-splash -close never -bg orange -fontsize large -text "$(gettext 'Reading modem configuration file...')" &
 X1PID=$!
 #disconnect button...
 STATECONb="disabled"
 #v409 rerwin, bugfix...
 #[ "`pidof pppd`" != "" ] && STATECONb="enabled"

Changes to woof-distro/arm/ubuntu/precise/DISTRO_PKGS_SPECS-ubuntu-precise

@@ -91,10 +91,11 @@
 yes|cyrus-sasl2|libsasl2-2,libsasl2-dev|exe,dev,doc,nls
 no|dbus|dbus,libdbus-1-3,libdbus-1-dev|exe,dev,doc,nls|+lsb-base
 no|dbus-glib|libdbus-glib-1-2,libdbus-glib-1-dev|exe,dev,doc,nls|+dbus
 yes|dbus||exe,dev,doc,nls
 yes|dbus-glib||exe,dev,doc,nls
+yes|d-conf|dconf-gsettings-backend,dconf-service,libdconf0,libdconf-dbus-1-0|exe,dev,doc,nls| #needed by gsettings-desktop-settings
 no|ddcprobe||exe,dev>null,doc,nls
 yes|debianutils|debianutils|exe,dev,doc,nls
 yes|defaults-chooser||exe|
 yes|desk_icon_theme_blue_moon||exe
 no|desk_icon_theme_jq8flat||exe
@@ -194,11 +195,11 @@
 yes|ghostscript||exe,dev,doc,nls
 no|gifsicle|gifsicle|exe,dev>null,doc,nls
 yes|gifsicle||exe,dev>null,doc,nls
 yes|git|git-core,gitweb,git-doc|exe>dev,dev,doc>dev,nls>dev
 yes|glade3|glade,libgladeui-2-0|exe>dev,dev,doc,nls
-yes|glib|libglib2.0-0,libglib2.0-data,libglib2.0-dev|exe,dev,doc,nls
+yes|glib|libglib2.0-bin,libglib2.0-0,libglib2.0-data,libglib2.0-dev|exe,dev,doc,nls
 yes|glibc|libc-bin,libc6,libc6-dev,tzdata|exe,dev,doc,nls
 yes|glibc_locales|locales|exe,dev,doc,nls>exe
 no|glibc_i18n_en||exe
 yes|glibmm|libglibmm-2.4-1c2a,libglibmm-2.4-dev|exe,dev,doc,nls
 yes|glipper||exe,dev>null,doc,nls
@@ -221,10 +222,11 @@
 yes|gphotofs|gphotofs|exe,dev,doc,nls
 yes|gpptp||exe
 yes|grep|grep|exe,dev>null,doc,nls
 yes|groff|groff|exe>dev,dev,doc,nls
 no|grub|grub|exe,dev>null,doc,nls
+yes|gsettings-desktop-schemas|gsettings-desktop-schemas|exe,dev,doc,nls| #needs d-conf.
 yes|gsm|libgsm1,libgsm1-dev|exe,dev,doc,nls
 yes|gtk+|libgtk2.0-0,libgtk2.0-dev|exe,dev,doc,nls
 yes|gtk2-engines-pixbuf|gtk2-engines-pixbuf|exe,dev,doc,nls
 yes|gtkam|gtkam|exe,dev>null,doc,nls|
 yes|gtk-chtheme|gtk-chtheme|exe,dev>null,doc,nls

Changes to woof-distro/x86/Packages-puppy-common-official

@@ -195,13 +195,15 @@
 libyahoo2-1.0.1-w5|libyahoo2|1.0.1-w5||BuildingBlock|164K||libyahoo2-1.0.1-w5.pet||yahoo chat library, used by ayttm|puppy|wary5||
 libyahoo2_DEV-1.0.1-w5|libyahoo2_DEV|1.0.1-w5||BuildingBlock|368K||libyahoo2_DEV-1.0.1-w5.pet|+libyahoo2|yahoo chat library, used by ayttm|puppy|wary5||
 linux_firewall-2.0rc9-puppy2|linux_firewall|2.0rc9-puppy2||Network|132K||linux_firewall-2.0rc9-puppy2.pet||Firewall||||
 linux_firmware_dvb-1.20|linux_firmware_dvb|1.20||BuildingBlock|48K||linux_firmware_dvb-1.20.pet||dvb usb kernel firmware||||
 linux_headers_DEV-2.6.32-40|linux_headers_DEV|2.6.32-40||BuildingBlock|4236K||linux_headers_DEV-2.6.32-40.pet||header files for 2.6.32.40 kernel||||
+linux_headers-3.2.17|linux_headers|3.2.17||BuildingBlock|4788K||linux_headers-3.2.17.pet||header files for 3.2.17 kernel||||
 linux_kernel-2.6.32-smp-45-i486-w5|linux_kernel|2.6.32-smp-45-i486-w5||BuildingBlock|83840K||linux_kernel-2.6.32-smp-45-i486-w5.pet||Linux kernel 2.6.32-smp-45 compiled in Wary Puppy version 5.1.2|puppy|wary5||
 linux_kernel-2.6.32-uni-45-i486-w5|linux_kernel|2.6.32-uni-45-i486-w5||BuildingBlock|82856K||linux_kernel-2.6.32-uni-45-i486-w5.pet||Linux kernel 2.6.32-uni-45 compiled in Wary Puppy version 5.1.2|puppy|wary5||
 linux_kernel-2.6.39-3-pae-i686-2-w5|linux_kernel|2.6.39-3-pae-i686-2-w5||BuildingBlock|65772K||linux_kernel-2.6.39-3-pae-i686-2-w5.pet||Linux kernel 2.6.39-3 compiled in Wary Puppy version 5.0|puppy|wary5||
+linux_kernel-3.2.17-pae-i686-aufs-w5|linux_kernel|3.2.17-pae-i686-aufs-w5||BuildingBlock|66064K||linux_kernel-3.2.17-pae-i686-aufs-w5.pet||Linux kernel 3.2.17 compiled in Wary Puppy version 5.1.2|puppy|wary5||
 madplay-0.15.2b-w5|madplay|0.15.2b-w5||Multimedia|80K||madplay-0.15.2b-w5.pet|+libid3tag,+libmad|A MPEG audio decoder program|puppy|wary5||
 madplay_DOC-0.15.2b-w5|madplay_DOC|0.15.2b-w5||Multimedia|44K||madplay_DOC-0.15.2b-w5.pet||A MPEG audio decoder program|puppy|wary5||
 madplay_NLS-0.15.2b-w5|madplay_NLS|0.15.2b-w5||Multimedia|92K||madplay_NLS-0.15.2b-w5.pet|+madplay|A MPEG audio decoder program|puppy|wary5||
 makebootfat-1.4-patched1-1|makebootfat|1.4-patched1-1||BuildingBlock|31K||makebootfat-1.4-patched1-1.pet||formats usb drive as bootable|puppy|4||
 man_cut-1.6e|man_cut|1.6e||BuildingBlock|48K||man_cut-1.6e.pet||only has man2html from man pkg|puppy|4||

Changes to woof-distro/x86/mageia/1/DISTRO_SPECS


Deleted woof-distro/x86/mageia/1/DISTRO_SPECS-HIDE-MAGEIA

Changes to woof-distro/x86/mageia/DISTRO_PET_REPOS

@@ -1,1 +1,22 @@
+#120515 customised for Mageia.
+
+#PKG_DOCS_PET_REPOS
+#where to download the pet pkgs databases from.
+#first field is for testing the url.
+#second field is full URI of the database file.
+#third field is name of db file when local and after being processed into standard format
+# (in the case of PET databases, the names are the same and no processing is required)
+#PET_REPOS
+#hardcode the pet repos in here...
+#first field is for testing the url.
+#second field is full URI of the repo
+#third field is the name of db-file(s) associated with that repo. it may have glob wildcards.
+# ex: Packages-puppy-4-official (note, url paths are in the database)
+#PACKAGELISTS_PET_ORDER
+#this defines where Woof looks first and second (and third, etc.) for pet pkgs
+
+PKG_DOCS_PET_REPOS="ibiblio.org|http://distro.ibiblio.org/quirky/Packages-puppy-wary5-official|Packages-puppy-wary5-official ibiblio.org|http://distro.ibiblio.org/quirky/Packages-puppy-common-official|Packages-puppy-common-official ibiblio.org|http://distro.ibiblio.org/quirky/Packages-puppy-noarch-official|Packages-puppy-noarch-official ibiblio.org|http://distro.ibiblio.org/quirky/Packages-puppy-drake-official|Packages-puppy-drake-official"
+
+PET_REPOS='ibiblio.org|http://distro.ibiblio.org/puppylinux|Packages-puppy-4-official ibiblio.org|http://distro.ibiblio.org/quirky|Packages-puppy-*-official ftp.nluug.nl|http://ftp.nluug.nl/ftp/pub/os/Linux/distr/quirky|Packages-puppy-*-official uoc.gr|http://ftp.cc.uoc.gr/mirrors/linux/quirky|Packages-puppy-*-official mirror.aarnet.edu.au|ftp://mirror.aarnet.edu.au/pub/quirky|Packages-puppy-*-official'
 
+PACKAGELISTS_PET_ORDER="Packages-puppy-drake-official Packages-puppy-noarch-official Packages-puppy-common-official Packages-puppy-wary5-official Packages-puppy-4-official"

Changes to woof-distro/x86/mageia/Packages-puppy-drake-official

@@ -1,1 +1,16 @@
-
+dhcpcd-5.2.12-i486-1-m1|dhcpcd|5.2.12-i486-1-m1||BuildingBlock|176K||dhcpcd-5.2.12-i486-1-m1.pet|+linux_kernel&ge2.6.39|network connection client daemon, requires kernel 2.6.39 or greater|mageia|1||
+dhcpcd_DOC-5.2.12-i486-m1|dhcpcd_DOC|5.2.12-i486-m1||BuildingBlock|64K||dhcpcd_DOC-5.2.12-i486-m1.pet||network connection client daemon||||
+ffmpeg-0.7.1-i686-m1|ffmpeg|0.7.1-i686-m1||Multimedia|4940K||ffmpeg-0.7.1-i686-m1.pet|+libgsm,+libvpx,+opencore-amr,+freetype,+libogg,+libvorbis,+lame,+faac,+speex,+x264,+libdc1394,+libtheora,+xvidcore,+schroedinger|cli media player and converter|mageia|1||
+ffmpeg_DEV-0.7.1-i686-m1|ffmpeg_DEV|0.7.1-i686-m1||Multimedia|6984K||ffmpeg_DEV-0.7.1-i686-m1.pet|+ffmpeg|cli media player and converter|mageia|1||
+ffmpeg_part_hack-2010-09-23-w5|ffmpeg_part_hack|2010-09-23-w5||BuildingBlock|20K||ffmpeg_part_hack-2010-09-23-w5.pet||libavcodec.so.0 out of wary5 ffmpeg, needed for mplayer out of wary used in drake. this is a bad hack but seems to work|puppy|wary5||
+iptables-1.4.11.1-i486|iptables|1.4.11.1-i486||BuildingBlock|1060K||iptables-1.4.11.1-i486.pet||kernel packet filtering|mageia|1||
+iptables_DEV-1.4.11.1-i486|iptables_DEV|1.4.11.1-i486||BuildingBlock|88K||iptables_DEV-1.4.11.1-i486.pet|+iptables|kernel packet filtering|mageia|1||
+iptables_DOC-1.4.11.1-i486|iptables_DOC|1.4.11.1-i486||BuildingBlock|84K||iptables_DOC-1.4.11.1-i486.pet||kernel packet filtering||||
+seamonkey-2.2-m1|seamonkey|2.2-m1||Internet|32156K||seamonkey-2.2-m1.pet|+libvpx,+alsa-lib,+cairo,+gtk+,+sqlite|full-featured web browser suite, with browser/mail&news/addressbook/composer|mageia|1||
+seamonkey_DEV-2.2-m1|seamonkey_DEV|2.2-m1||BuildingBlock|33500K||seamonkey_DEV-2.2-m1.pet|+seamonkey&eq2.2|Seamonkey browser suite|mageia|1||
+x264-20110726-116-m1|x264|20110726-116-m1||BuildingBlock|780K||x264-20110726-116-m1.pet||video codec library|mageia|1||
+x264_DEV-20110726-116-m1|x264_DEV|20110726-116-m1||BuildingBlock|968K||x264_DEV-20110726-116-m1.pet|+x264|video codec library|mageia|1||
+xorg-server-1.10.1-i486|xorg-server|1.10.1-i486||BuildingBlock|3664K||xorg-server-1.10.1-i486.pet||X.org server|mageia|1||
+xorg-server_DEV-1.10.1-i486|xorg-server_DEV|1.10.1-i486||BuildingBlock|1596K||xorg-server_DEV-1.10.1-i486.pet|+xorg-server|X.org server|mageia|1||
+xorg-server-no_udev-1.10.1-i486|xorg-server-no_udev|1.10.1-i486||BuildingBlock|3640K||xorg-server-no_udev-1.10.1-i486.pet||X.org server, compiled without hal and udev ability|mageia|1||
+xorg-server-no_udev_DEV-1.10.1-i486|xorg-server-no_udev_DEV|1.10.1-i486||BuildingBlock|1596K||xorg-server-no_udev_DEV-1.10.1-i486.pet|+xorg-server-no_udev|X.org server, no udev support|mageia|1||

Changes to woof-distro/x86/mageia/cauldron/DISTRO_COMPAT_REPOS-mageia-cauldron

@@ -1,1 +1,8 @@
+#where to get pkg docs, format: domain|uri|localfilename...
+#note, DISTRO_BINARY_COMPAT=mageia, DISTRO_COMPAT_VERSION=cauldron
+PKG_DOCS_DISTRO_COMPAT="mirror.aarnet.edu.au|http://mirror.aarnet.edu.au/pub/mageia/distrib/cauldron/i586/media/core/release/media_info/synthesis.hdlist.cz|Packages-mageia-cauldron-core mirror.aarnet.edu.au|http://mirror.aarnet.edu.au/pub/mageia/distrib/cauldron/i586/media/nonfree/release/media_info/synthesis.hdlist.cz|Packages-mageia-cauldron-nonfree mirror.aarnet.edu.au|http://mirror.aarnet.edu.au/pub/mageia/distrib/cauldron/i586/media/tainted/release/media_info/synthesis.hdlist.cz|Packages-mageia-cauldron-tainted"
 
+#mageia package repos (see mirrors.mageia.org for full list)...
+#note, there are three repo groups 'core', 'nonfree' and 'tainted'.
+#note, the local pkgs database file (or partname) is also appended to these entries, so know which url to download a particular pkg from...
+REPOS_DISTRO_COMPAT="mirror.aarnet.edu.au|http://mirror.aarnet.edu.au/pub/mageia/distrib/cauldron/i586/media|Packages-mageia-cauldron-* mageia.c3sl.ufpr.br|http://mageia.c3sl.ufpr.br/distrib/cauldron/i586/media|Packages-mageia-cauldron-* ftp.fi.muni.cz|http://ftp.fi.muni.cz/pub/linux/mageia/distrib/cauldron/i586/media|Packages-mageia-cauldron-* distro.ibiblio.org|http://distro.ibiblio.org/mageia/distrib/cauldron/i586/media|Packages-mageia-cauldron-* ftp-stud.hs-esslingen.de|http://ftp-stud.hs-esslingen.de/pub/Mirrors/Mageia/distrib/cauldron/i586/media|Packages-mageia-cauldron-* ftp.nluug.nl|http://ftp.nluug.nl/pub/os/Linux/distr/mageia/distrib/cauldron/i586/media|Packages-mageia-cauldron-*"

Changes to woof-distro/x86/mageia/cauldron/DISTRO_PKGS_SPECS-mageia-cauldron

@@ -1,1 +1,665 @@
+#fallbacks when looking for pkgs (space-separated list)...
+FALLBACKS_COMPAT_VERSIONS='cauldron 1'
+
+#PKGS_SPECS_TABLE table format:
+#will pkg be in puppy-build.
+#    Generic name for pkg. Note: PET packages, if exist, use this name.
+#            Comma-separated list of compatible-distro pkg(s). '-' prefix, exclude.
+#            Must be exact name-only of pkg, else '*' on end is wildcard to search full name.
+#            Empty field, then use PET pkg.
+#                                    How the package will get split up in woof (optional redirection '>' operator).
+#                                    Missing field, it goes into exe. Can also redirect >null, means dump it.
+#yes|abiword|iceword,iceword-plugins|exe,dev,doc,nls
+
+#example showing wildcard. finds all full pkg names with 'gcc-4.3*',
+#but, exclude any 'gcc-4.3-doc*' matches...
+# yes|gcc|gcc,gcc-4.3*,-gcc-4.3-doc*|exe,dev,doc,nls
+
+#110817 Comments preferred to be on end of line, ex:
+# yes|abiword|iceword,iceword-plugins|exe,dev,doc,nls| #this is a comment.
+
+#110829 enhancements:
+#                                                     Force pkg is from compat-distro repo, specifically 'salix' repo.
+# yes|abiword|iceword,iceword-plugins|exe,dev,doc,nls|compat:salix
+#Generic format:
+# yes|genericpkgname|[pkgnames]|[splitup]|[pet:[repo]]
+# yes|genericpkgname|[pkgnames]|[splitup]|[compat:[repo]]
+#for a fuller explanation of the entries in PKGS_SPECS_TABLE, please see:
+# http://bkhome.org/blog/?viewDetailed=02414
 
+PKGS_SPECS_TABLE='
+yes|915resolution||exe,dev,doc,nls|
+yes|a52dec|a52dec,liba52dec0,liba52dec-devel|exe,dev,doc,nls|
+yes|abiword|abiword,abiword-devel|exe,dev,doc,nls| #uses aiksaurus, libgtkmathview, link-grammar, avahi, libcroco, enchant
+yes|acl|libacl1,libacl-devel|exe,dev,doc,nls|
+yes|aiksaurus|aiksaurus,aiksaurus-data,aiksaurusgtk,libaiksaurus1.2_0,libaiksaurusgtk1.2_0,libaiksaurusgtk-devel|exe,dev,doc,nls| #needed by abiword.
+yes|align||exe|
+yes|alsa-lib|libalsa2,libalsa2-devel,libalsa-data,libalsa-oss0,libalsa-oss-devel,libalsa-plugins|exe,dev,doc,nls|
+yes|alsa-utils|alsa-utils|exe,dev,doc,nls|
+no|asapm||exe|
+yes|aspell|libaspell15,libaspell-devel|exe,dev,doc,nls|
+no|assuan|libassuan0,libassuan-devel|exe,dev,doc,nls| #needed by gpgme.
+yes|atk|atk1.0-common,libatk1.0_0,libatk1.0-devel|exe,dev,doc,nls|
+yes|attr|libattr1,libattr1-devel|exe,dev,doc,nls|
+yes|audiofile|libaudiofile0,libaudiofile0-devel|exe,dev,doc,nls|
+yes|audit|libaudit1,libaudit-devel|exe,dev,doc,nls|
+yes|aufs2-util||exe| #note, kernel-version dependent.
+yes|autoconf|autoconf|exe>dev,dev,doc,nls|
+no|autologin||exe|
+yes|automake|automake|exe>dev,dev,doc,nls|
+yes|avahi|avahi,avahi-x11,libavahi-client3,libavahi-client-devel,libavahi-common3,libavahi-common-devel,libavahi-glib1,libavahi-glib-devel,libavahi-core7,libavahi-core-devel,libavahi-gobject0,libavahi-gobject-devel,libavahi-ui1,libavahi-ui-devel|exe,dev,doc,nls|
+yes|axel||exe,dev>null,doc,nls|
+yes|ayttm||exe,dev>null,doc,nls|
+yes|bacon||exe,dev,doc>dev,nls|
+yes|bash||exe,dev>null,doc,nls|
+yes|bbc_provided||exe|
+yes|bc|bc|exe,dev>null,doc,nls|
+yes|bdb|libdb4.8,libdb4.8-devel,libdbnss4.8,libdbnss4.8-devel|exe,dev,doc,nls| #berkeley database, maybe incomplete.
+yes|bcrypt||exe|
+yes|binutils|binutils,libbinutils-devel|exe>dev,dev,doc,nls|
+yes|bison|bison|exe>dev,dev,doc,nls|
+no|bluez|libbluez3,libbluez-devel|exe,dev,doc,nls| #needed by pilot-link. incomplete
+yes|boehm-gc|libgc1,libgc-devel|exe,dev,doc,nls|
+yes|bones||exe|
+yes|busybox||exe,dev>null,doc,nls|
+yes|bzip2|bzip2,libbzip2_1,libbzip2-devel|exe,dev,doc,nls|
+yes|cairo|libcairo2,libcairo-devel,libcairo-xcb2,libcairo-xcb-devel|exe,dev,doc,nls|
+yes|cddetect||exe,dev>null,doc,nls|
+yes|cdparanoia|cdparanoia,libcdda0,libcdda-devel|exe,dev,doc,nls|
+no|cdrkit||exe,dev>null,doc,nls|
+yes|cdrkit|cdrkit,cdrkit-genisoimage,cdrkit-icedax,cdrkit-isotools|exe,dev,doc,nls|
+yes|cgtkcalc||exe,dev>null,doc,nls|
+no|chmlib||exe,dev,doc,nls|
+no|chmsee||exe,dev>null,doc,nls|
+no|coreutils|coreutils|exe,dev>null,doc,nls| #no, need pet...
+yes|coreutils||exe|
+yes|close-dvd+rwtools||exe|
+yes|cmake|cmake|exe>dev,dev,doc,nls|
+yes|cpio|cpio|exe,dev>null,doc,nls|
+no|cpu-scaling-ondemand||exe|
+no|cups|cups,cups-common,cups-drivers-*,cups-pdf,cups-serial,libcups2,libcups2-devel|exe,dev,doc>exe,nls| #too big
+yes|cups||exe,dev,doc,nls|
+yes|cups_pdf||exe|
+yes|curl|curl,libcurl4,libcurl-devel|exe,dev,doc,nls|
+yes|cvs|cvs|exe>dev,dev,doc,nls|
+yes|cyrus-sasl2|libsasl2,libsasl2-devel|exe,dev,doc,nls| #incomplete?
+yes|dbus||exe,dev,doc,nls|
+yes|dbus-glib||exe,dev,doc,nls|
+yes|ddcprobe||exe,dev>null,doc,nls|
+yes|defaults-chooser||exe|
+yes|desk_icon_theme_jq8flat||exe|
+no|desk_icon_theme_original||exe|
+yes|desk_icon_theme_smooth_color||exe|
+yes|desk_icon_theme_stardust||exe|
+yes|dev86|dev86,dev86-devel|exe>dev,dev,doc,nls|
+no|dhcpcd|dhcpcd|exe,dev>null,doc,nls|
+yes|dhcpcd||exe|
+yes|dialog|cdialog|exe,dev>null,doc,nls|
+yes|dictd_client||exe|
+yes|didiwiki||exe|
+yes|dietlibc||exe>dev,dev,doc,nls|
+yes|diffstat|diffstat|exe,dev>null,doc,nls|
+yes|diffutils|diffutils|exe,dev>null,doc,nls|
+yes|directfb|libdirectfb1.4_5,libdirectfb-devel|exe,dev,doc,nls| #needed by libSDL
+yes|disktype||exe,dev>null,doc,nls|
+yes|dmidecode|dmidecode|exe,dev>null,doc,nls|
+yes|dosfstools|dosfstools|exe,dev>null,doc,nls|
+yes|dpkg-deb|dpkg|exe,dev>null,doc,nls|
+yes|dvdauthor|dvdauthor|exe,dev,doc,nls|
+yes|dvd+rwtools|dvd+rw-tools|exe,dev,doc,nls|
+yes|e2fsprogs|e2fsprogs,libblkid1,libblkid-devel,libext2fs2,libext2fs-devel,libuuid1,libuuid-devel|exe,dev,doc,nls|
+yes|e3_utf8||exe|
+yes|ed|ed|exe,dev>null,doc,nls|
+yes|edid||exe|
+yes|eject|eject|exe,dev>null,doc,nls|
+yes|elspci||exe,dev>null,doc,nls|
+yes|embutils_cut||exe|
+yes|enchant|enchant,libenchant1,libenchant-devel|exe,dev,doc,nls|
+yes|epdfview|epdfview|exe,dev>null,doc,nls|
+yes|ethtool|ethtool|exe,dev>null,doc,nls|
+yes|exiv2|exiv2,libexiv2_10,libexiv2-devel|exe,dev,doc,nls|
+yes|expat|expat,libexpat1,libexpat1-devel|exe,dev,doc,nls|
+yes|faac||exe,dev,doc,nls| #needed by my ffmpeg pet. wary5.
+yes|faad|faad2,libfaad2_2,libfaad2-devel|exe,dev,doc,nls| #tainted
+no|fbpanel||exe,dev>null,doc,nls|
+no|ffmpeg|ffmpeg,libavformats52,libavutil50,libffmpeg52,libffmpeg-devel,libpostproc51,libSDL1.2_0,libswscaler0|exe,dev,doc,nls|
+yes|ffmpeg||exe,dev,doc,nls| #problem compiling mplayer with official ffmpeg, use my pet. needs pets: libdv, faac, x264.
+no|ffmpeg||exe,dev,doc,nls|
+yes|ffmpeg_part_hack||exe| #ffmpeg compiled in drake has missing libavcore.so, needed by mplayer that was compiled in wary.
+no|file|file,libmagic1,libmagic-devel|exe,dev,doc,nls|
+yes|file||exe,dev,doc,nls|
+yes|file_sharing-curlftpfs-mpscan||exe|
+yes|findutils|findutils|exe,dev>null,doc,nls|
+yes|flac|libflac8,libflac-devel|exe,dev,doc,nls| #have left out flac, which is enormous. needed by libsndfile
+no|flashplayer10||exe|
+yes|flex|flex|exe>dev,dev,doc,nls|
+yes|fonttosfnt|fonttosfnt|exe,dev,doc,nls #needed by x11-font-util
+yes|foomatic-db-engine|foomatic-db-engine|exe,dev,doc,nls|
+yes|foomatic-filters|foomatic-filters|exe,dev,doc,nls|
+yes|fossil||exe>dev,dev,doc>dev,nls
+no|fotoxx||exe,dev>null,doc,nls|
+yes|fpm2||exe|
+yes|freememapplet_tray||exe|
+yes|freetype|libfreetype6,libfreetype6-devel|exe,dev,doc,nls|
+yes|fribidi|libfribidi0,libfribidi-devel|exe,dev,doc,nls|
+yes|fstobdf|fstobdf|exe,dev,doc,nls| #needed by x11-font-util
+yes|fuse|fuse,libfuse2,libfuse-devel|exe,dev,doc,nls|
+yes|gail|libgail18,libgail-devel|exe,dev,doc,nls| #needed by libgnomecanvas
+yes|gamin|gamin,libgamin-1_0,libgamin-1_0-devel|exe,dev,doc,nls| #needed by gio
+yes|gawk|gawk|exe,dev,doc,nls|
+yes|gcc_dev|gcc,glibc,glibc-devel,gcc-cpp,libgcc1,gcc-c++,libstdc++6,libstdc++-devel,gcc-gfortran,libgfortran3|exe>dev,dev,doc,nls|
+yes|gcc_lib|libgcc1,libgomp1,libgomp-devel|exe,dev,doc,nls|
+yes|gccmakedep|gccmakedep|exe>dev,dev,doc,nls|
+yes|gcolor2||exe,dev>null,doc,nls|
+yes|gconf|GConf2,libGConf2_4,libGConf2-devel|exe,dev,doc,nls|
+yes|gdb|gdb|exe>dev,dev,doc,nls|
+yes|gdbm|libgdbm3,libgdbm-devel|exe,dev,doc,nls|
+yes|gdmap||exe,dev>null,doc,nls|
+yes|geany|geany|exe,dev>null,doc,nls|
+yes|getcurpos||exe|
+yes|getdir||exe,dev>null,doc,nls|
+yes|gettext_dev|gettext-base,gettext,gettext-devel,libgettextmisc,libintl8|exe>dev,dev,doc,nls|
+yes|gettext|gettext-base,gettext,libgettextmisc,libintl8|exe,dev>null,doc>null,nls>null|
+yes|gexec||exe,dev>null,doc,nls|
+yes|gfnrename||exe,dev>null,doc,nls|
+yes|gfontsel||exe,dev>null,doc,nls|
+yes|gftp|gftp|exe,dev>null,doc,nls|
+no|ghostscript|ghostscript,ghostscript-common,ghostscript-dvipdf,ghostscript-module-X,ghostscript-X,libgs9,libgs9-devel|exe,dev,doc,nls|
+yes|ghostscript||exe,dev,doc,nls|
+yes|gifsicle||exe,dev>null,doc,nls|
+yes|glade3|glade3,libgladeui1_11,libgladeui1-devel|exe>dev,dev,doc,nls|
+yes|glib|glib2.0-common,libglib2.0_0,libglib2.0-devel,glib-gettextize,libgio2.0_0|exe,dev,doc,nls| #these have extra deps: ,glib-networking,libglib-networking. note libgio needs libgamin.
+yes|glibc|glibc,glibc-devel,glibc-utils|exe,dev,doc,nls|
+yes|glibc_locales|glibc-i18ndata,|exe,dev,doc,nls>exe| #glibc-i18ndata is very big, wonder if pkg locales needed here?
+yes|glipper||exe,dev>null,doc,nls|
+yes|gmeasures||exe,dev>null,doc,nls|
+yes|gmp|libgmp10,libgmp-devel,libgmpxx4,libgmpxx-devel|exe>dev,dev,doc,nls| #needed by gcc
+yes|gnome-doc-utils|gnome-doc-utils|exe>dev,dev,doc,nls|
+yes|gnome-keyring|libgnome-keyring0,libgnome-keyring-i18n|exe,dev,doc,nls| #left out gnome-keyring, libgnome-keyring-devel
+yes|gnome-menus|libgnome-menu2|exe,dev,doc,nls| #left out gnome-menus, libgnome-menu-devel
+yes|gnome-vfs|libgnome-vfs2_0|exe,dev,doc,nls| #left out gnome-vfs2, libgnome-vfs2-devel
+yes|gnumeric|gnumeric,libspreadsheet1.10.14,libspreadsheet-devel|exe,dev,doc,nls|
+no|gnupg|gnupg,gnupg2|exe,dev,doc,nls #needed by gpgme. these are big.
+yes|gnutls|gnutls,libgnutls26,libgnutls-devel|exe,dev,doc,nls|
+yes|goffice|goffice,libgoffice0.8_8,libgoffice0.8-devel|exe,dev,doc,nls|
+yes|gparted||exe,dev>null,doc,nls|
+no|gpgme|libgpgme11,libgpgme-devel|exe,dev,doc,nls| #needed by sylpheed, maybe more. needs gnupg, gnupg2.
+yes|gphoto2|gphoto2,libgphoto2,libgphoto-common,libgphoto-devel|exe,dev,doc,nls|
+yes|gphotofs|gphotofs|exe,dev,doc,nls
+yes|gpm|gpm,libgpm2,libgpm-devel|exe,dev,doc,nls
+yes|gpptp||exe|
+yes|grep|grep|exe,dev>null,doc,nls|
+yes|groff|groff,groff-perl,groff-x11,groff-for-man|exe>dev,dev,doc,nls|
+yes|grub||exe|
+yes|gsm|libgsm1,libgsm-devel|exe,dev,doc,nls|
+yes|gtk+|gtk+2.0,libgtk+2.0_0,libgtk+-x11-2.0_0,libgtk+2.0-devel,libgdk_pixbuf2.0_0,libgdk_pixbuf2.0-devel|exe,dev,doc,nls|
+no|gtk2-engines-pixbuf||exe,dev,doc,nls| #dont know about this
+no|gtkam||exe,dev>null,doc,nls| #strange, not in mageia repo.
+yes|gtk-chtheme|gtk-chtheme|exe,dev>null,doc,nls|
+no|gtkdialog2||exe|
+yes|gtkdialog3||exe,dev,doc>dev,nls|
+yes|gtkdialog4||exe,dev,doc>dev,nls| #modify all pets that need this to explicitly call 'gtkdialog' or 'gtkdialog4'.
+yes|gtkhash||exe|
+yes|gtk_theme_citrus_cut||exe|
+no|gtk_theme_flat_grey||exe|
+yes|gtk_theme_flat_grey_rounded||exe|
+yes|gtk_theme_gradient_brown||exe|
+yes|gtk_theme_gradient_grey||exe|
+no|gtk_theme_stardust_zigbert||exe|
+#my pet with genie.lang added... no, now in template...
+no|gtksourceview||exe,dev,doc,nls
+yes|gtksourceview|gtksourceview,libgtksourceview-2.0_0,libgtksourceview-2.0-devel|exe,dev,doc,nls|
+yes|gtkspell|gtkspell,libgtkspell0,libgtkspell-devel|exe,dev,doc,nls|
+no|gtrayicon||exe|
+yes|guess_fs||exe|
+yes|gutenprint|gutenprint-common,gutenprint-cups,gutenprint-escputil,gutenprint-gimp2,gutenprint-ijs,libgutenprint2,libgutenprint2-devel,libgutenprintui2_1,libgutenprintui2_1-devel|exe,dev,doc,nls|
+no|gview||exe| #very basic image viewer, but we are using viewnior.
+yes|gwhere||exe|
+yes|gxmessage||exe,dev,doc,nls| #use my pet, as has xmessage symlink to gxmessage.
+yes|gzip|gzip|exe,dev>null,doc,nls|
+yes|hal||exe,dev,doc,nls| #my cutdown pet. needs udev, libvolume-id
+yes|hardinfo||exe,dev,doc,nls|
+yes|hdparm|hdparm|exe,dev>null,doc,nls|
+yes|helpsurfer||exe|
+yes|hiawatha||exe|
+yes|hicolor-icon-theme|hicolor-icon-theme|exe,dev>null,doc,nls|
+yes|homebank|homebank|exe,dev>null,doc,nls| #requires libofx and OpenSP -- rather big.
+yes|hotplug2stdout||exe|
+yes|hunspell|hunspell,libhunspell1.2_0,libhunspell-devel|exe,dev,doc,nls|
+yes|hunspell-en|hunspell-en|exe,dev,doc,nls|
+yes|id3lib|id3lib,libid3_3.8_3,libid3_3.8_3-devel|exe,dev,doc,nls|
+yes|ifplugd||exe|
+yes|ifplugd_old||exe|
+yes|ijs|libijs1,libijs1-devel|exe,dev,doc,nls|
+no|imagination||exe|
+yes|imake|imake|exe>dev,dev,doc,nls|
+yes|initscripts|initscripts|exe,dev,doc,nls|
+yes|inkscapelite||exe|
+yes|inotail||exe,dev,doc,nls|
+yes|inotify-tools|inotify-tools,libinotifytools0,libinotifytools-devel|exe,dev,doc,nls|
+yes|installwatch||exe|
+yes|intltool|intltool|exe>dev,dev,doc,nls|
+no|iptables|iptables,libip4tc0,libip4tc-devel,libip6tc0,libip6tc-devel,libiptables5,libiptables-devel|exe,dev,doc,nls|
+yes|iptables||exe,dev,doc,nls| #missing libs in mageia iptables, i compiled it.
+yes|isomaster||exe,dev,doc,nls|
+yes|jasper|jasper,libjasper1,libjasper-devel|exe,dev,doc,nls
+yes|jbig2dec|jbig2dec,libjbig2dec0,libjbig2dec-devel|exe,dev,doc,nls|
+yes|jimtcl||exe|
+yes|jwm2||exe|
+yes|jwmconfig2||exe|
+yes|jwmthememaker||exe|
+no|kbd||exe,dev,doc,nls|
+yes|keyutils|keyutils,libkeyutils1,libkeyutils-devel|exe,dev>null,doc,nls|
+yes|krb5|krb5,libkrb53,libkrb53-devel|exe,dev,doc,nls|
+yes|lame|lame,lame-mp3x,liblame0,liblame-devel|exe,dev,doc,nls| #tainted
+yes|lcms|lcms,liblcms1,liblcms-devel|exe,dev,doc,nls|
+no|leafpad|leafpad|exe,dev>null,doc,nls| #we are using nicoedit.
+yes|less|less|exe,dev>null,doc,nls|
+yes|lhp_sys_info||exe
+yes|libaa|libaa1,libaa-devel|exe,dev,doc,nls| #needed by gphoto2
+yes|libao|libao4,libao-devel|exe,dev,doc,nls|
+yes|libarchive|libarchive2,libarchive-devel|exe,dev,doc,nls|
+yes|libart|libart_lgpl2,libart_lgpl-devel|exe,dev,doc,nls|
+yes|libasyncns|libasyncns0,libasyncns-devel|exe,dev,doc,nls|
+yes|libavc1394|libavc1394_0,libavc1394-devel,libavc1394-tools|exe,dev,doc,nls| #needs libraw1394
+yes|libbonobo|libbonobo2_0,libbonobo2_0-devel,libbonobo,libbonoboui2_0,libbonoboui,libbonoboui2-devel|exe,dev,doc,nls|
+no|libcaca|libcaca0,libcaca-devel|exe,dev,doc,nls|
+yes|libcanberra|canberra-common,libcanberra0,libcanberra-devel|exe,dev,doc,nls| #needed by libbonobo
+yes|libcap|libcap2,libcap-devel|exe,dev,doc,nls|
+yes|libcddb|libcddb2,libcddb-devel,libcddb-apps|exe,dev,doc,nls|
+yes|libcdio|libcdio++0,libcdio12,libcdio-apps,libcdio_cdda0,libiso9660_7,libcdio-devel|exe,dev,doc,nls|
+yes|libconfig|libconfig9,libconfig-devel|exe,dev,doc,nls| #needed by ntfsutils
+yes|libcrack|libcrack2|exe,dev,doc,nls| #needed by pam. left out libcrack-devel
+yes|libcroco|libcroco0.6_3,libcroco0.6_3-devel,libcroco0.6-utils|exe,dev,doc,nls|
+yes|libdaemon|libdaemon0,libdaemon-devel|exe,dev,doc,nls|
+yes|libdatrie|libdatrie1,libdatrie-devel|exe,dev>null,doc,nls|
+yes|libdc1394|libdc1394_22,libdc1394-devel|exe,dev,doc,nls| #needed by ffmpeg
+yes|libdevmapper|libdevmapper1.02,libdevmapper-devel,libdevmapper-event1.02,libdevmapper-event-devel|exe,dev,doc,nls|
+yes|libdrm|libdrm2,libdrm-common,libdrm-devel,libdrm_intel1,libdrm_nouveau1,libdrm-psb2,libdrm-psb-devel,libdrm_radeon1,libkms1|exe,dev,doc,nls| #needed by xorg
+yes|libdv||exe,dev,doc,nls| #needed by my ffmpeg pet from wary5.
+yes|libdvdcss|libdvdcss2,libdvdcss-devel|exe,dev,doc,nls| #tainted
+yes|libdvdnav|libdvdnav4,libdvdnav-devel|exe,dev,doc,nls|
+no|libdvdplay||exe,dev,doc,nls
+yes|libdvdread|libdvdread4,libdvdread-devel|exe,dev,doc,nls|
+yes|libedit|libedit,libedit-devel|exe,dev,doc,nls|
+yes|libelfutils|libelfutils1,libelfutils-devel|exe>dev,dev,doc,nls| #needed by gcc
+yes|libexif|libexif12,libexif12-common,libexif-devel|exe,dev,doc,nls|
+yes|libexif-gtk||exe,dev,doc,nls| #hmmm, no mageia pkg
+yes|libfontenc1|libfontenc1,libfontenc-devel|exe,dev,doc,nls| #needed by mkfontscale
+yes|libfs|libfs6,libfs-devel|exe,dev,doc,nls| #font server lib. needed by x11-font-util.
+yes|libgcrypt|libgcrypt11,libgcrypt-devel|exe,dev,doc,nls|
+yes|libgd2|libgd2,libgd-devel|exe,dev,doc,nls|
+yes|libgee|libgee2,libgee-devel|exe,dev,doc,nls|
+yes|libggi|libggi,libggi2|exe,dev,doc,nls| #needed by libSDL. left out libggi-devel
+yes|libgif|libgif4,libgif-devel|exe,dev,doc,nls|
+yes|libgii|libgii,libgii1|exe,dev,doc,nls| #needed by libggi. left out libgii-devel
+yes|libgimp|libgimp2.0_0,libgimp2.0-devel|exe,dev,doc,nls| #part of gimp pkg, xsane gimp plugin needs this.
+yes|libglade2|libglade2.0_0,libglade2.0_0-devel|exe,dev,doc,nls|
+yes|libgnome|libgnome2,libgnome2_0,libgnome2-devel|exe,dev,doc,nls| #left out libgnome2-schemas
+yes|libgnomecanvas2|libgnomecanvas,libgnomecanvas2_0,libgnomecanvas2-devel|exe,dev,doc,nls| #needs gail
+yes|libgnomecups|libgnomecups,libgnomecups-1.0_1,libgnomecups-1.0-devel|exe,dev,doc,nls|
+yes|libgnomeprint|libgnomeprint,libgnomeprint2-2_0,libgnomeprint2-2-devel|exe,dev,doc,nls|
+yes|libgnomeprintui|libgnomeprintui,libgnomeprintui2-2_0,libgnomeprintui2-2-devel|exe,dev,doc,nls|
+yes|libgnomeui|libgnomeui2,libgnomeui2_0,libgnomeui2-devel|exe,dev,doc,nls|
+yes|libgpg-error|libgpg-error0,libgpg-error-common,libgpg-error-devel|exe,dev,doc,nls|
+yes|libgphoto2|libgphoto2,libgphoto-common,libgphoto-devel|exe,dev,doc,nls|
+yes|libgsf|libgsf,libgsf-1_114,libgsf-1-devel|exe,dev,doc,nls|
+yes|libgtkhtml2|libgtkhtml2_0,libgtkhtml2-devel|exe,dev,doc,nls| #be careful, there are two very different libgtkhtml pkgs, we need the old 2.11.1.
+yes|libgtkmathview|libgtkmathview0,libgtkmathview-devel|exe,dev,doc,nls| #needed by abiword
+yes|libical|libical0,libical-devel,libicalss0,libicalvcal0|exe,dev,doc,nls|
+yes|libid3tag|libid3tag0,libid3tag-devel|exe,dev,doc,nls|
+yes|libidl|libIDL2_0,libIDL2-devel|exe,dev,doc,nls|
+yes|libidn|libidn11,libidn-devel|exe,dev,doc,nls|
+yes|libieee1284|libieee1284_3,libieee1284-devel|exe,dev,doc,nls|
+no|libiptcdata|libiptcdata0,libiptcdata-devel,libiptcdata-i18n,libiptcdata-utils|exe,dev,doc,nls|
+yes|libjack|libjack0|exe,dev,doc,nls| #needed by ffmpeg. leave out libjack-devel, jackit
+yes|libjbig|libjbig1,libjbig-devel|exe,dev,doc,nls| #needed by cups
+no|libjpeg|libjpeg62,libjpeg62-dev|exe,dev,doc,nls
+yes|libjpeg_old6|libjpeg62|exe,dev,doc,nls|
+yes|libjpeg_old7||exe,dev,doc,nls| #pet in the common repo.
+yes|libjpeg|libjpeg8,libjpeg-devel|exe,dev,doc,nls| #generic name must be libjpeg, as has template
+yes|liblockdev|liblockdev1,liblockdev1-devel|exe,dev,doc,nls|
+yes|libloudmouth|libloudmouth-1_0,libloudmouth-devel|exe,dev,doc,nls|
+yes|libltdl|libltdl7,libltdl-devel|exe,dev,doc,nls| #note, this is really part of libtool pkg, but libs needed at runtime.
+yes|liblzo|liblzo2_2,liblzo-devel|exe,dev,doc,nls|
+yes|libmad|libmad0,libmad-devel|exe,dev,doc,nls|
+yes|libmodman|libmodman1|exe,dev,doc,nls| #needed by libsoup
+yes|libmcrypt|libmcrypt,libmcrypt4,libmcrypt-devel|exe,dev,doc,nls|
+yes|libmng|libmng1,libmng-devel|exe,dev,doc,nls|
+no|libmozjs1d||exe| #just provides symlinks into seamonkey.
+yes|libnl|libnl1,libnl-devel|exe,dev,doc,nls|
+yes|libneon|libneon0.27|exe>dev,dev,doc,nls| #needed by subversion. left out libneon0.27-devel
+yes|libnotify|libnotify,libnotify1,libnotify-devel|exe,dev,doc,nls|
+yes|libofx|libofx,libofx4,libofx-devel|exe,dev,doc,nls| #needed by homebank, see also opensp
+yes|libogg|libogg0,libogg-devel|exe,dev,doc,nls|
+yes|liboil|liboil0.3_0,liboil-devel,liboil-tools|exe,dev,doc,nls|
+yes|libopencore-amr|libopencore-amr0,libopencore-amr-devel|exe,dev,doc,nls| #tainted. needed by ffmpeg
+yes|libpaper|libpaper1,libpaper-devel,paper-utils|exe,dev,doc,nls|
+yes|libpcap|libpcap1,libpcap-devel|exe,dev,doc,nls|
+yes|libpciaccess|libpciaccess0,libpciaccess-devel|exe,dev,doc,nls|
+yes|libpcsclite|libpcsclite1,libpcsclite-devel|exe,dev,doc,nls| #needed by wpa_supplicant, etc
+yes|libpng|libpng3,libpng-devel,libpnglite0|exe,dev,doc,nls| #libpnglite0 provides the old libpng 1.2.x
+yes|libproxy|libproxy1,libproxy-devel|exe,dev,doc,nls #needed by libsoup, maybe others. note, there are more libproxy-*
+yes|libpth|libpth20,libpth-devel|exe,dev,doc,nls| #needed by libgcrypt
+yes|libpthread-stubs|libpthread-stubs|exe>dev,dev,doc,nls|
+yes|libpulseaudio|libpulseaudio0|exe,dev,doc,nls| #leave out libpulseaudio-devel
+yes|libraw1394|libraw1394_11,libraw1394-devel,libraw1394-utils|exe,dev,doc,nls|
+yes|librsvg|librsvg,librsvg2_2,librsvg2-devel|exe,dev,doc,nls|
+yes|librtmp|librtmp0,librtmp-devel|exe,dev,doc,nls| #needed by ffmpeg
+yes|libsamplerate|libsamplerate0,libsamplerate-devel,libsamplerate-progs|exe,dev,doc,nls|
+yes|libserf|libserf0|exe>dev,dev,doc,nls| #needed by subversion. left out libserf-devel
+yes|libsigc++|libsigc++2.0_0,libsigc++2.0-devel|exe,dev,doc,nls|
+yes|libsigsegv|libsigsegv2,libsigsegv-devel|exe,dev,doc,nls|
+yes|libsndfile|libsndfile1,libsndfile-devel,libsndfile-progs|exe,dev,doc,nls|
+yes|libsoup|libsoup-2.4_1,libsoup-2.4-devel|exe,dev,doc,nls| #needs libproxy
+yes|libssh2|libssh2_1,libssh2-devel|exe,dev,doc,nls|
+yes|libstdc++||exe,dev>null,doc>null,nls>null| #old libstdc++.so.5. some video codecs (/usr/lib/codecs) need it.
+yes|libstdc++6|libstdc++6,libstdc++-devel|exe,dev,doc,nls| #umm, duplicated, see gcc pkg.
+yes|libtar|libtar,libtar-devel|exe,dev,doc,nls|
+yes|libtasn1|libtasn1_3,libtasn1-devel,libtasn1-tools|exe,dev,doc,nls| #needed by gnutls i think.
+yes|libtdb|libtdb1,libtdb-devel|exe,dev,doc,nls| #needed by libcanberra
+yes|libthai|libthai0,thai-data|exe,dev>null,doc,nls| #needed by a pango thailand module. leave out libthai-devel
+yes|libtheora|libtheora0,libtheoradec1,libtheora-devel,libtheoraenc1|exe,dev,doc,nls|
+yes|libtiff|libtiff3,libtiff-devel|exe,dev,doc,nls| #note, debian squeeze has libtiff4. left out libtiff-progs
+yes|libtool|libtool,libtool-base|exe>dev,dev,doc,nls| #see libltdl above.
+yes|libunique|libunique0,libunique-devel|exe,dev,doc,nls|
+yes|libunistring|libunistring0,libunistring-devel|exe,dev,doc,nls| #needed by gettext
+yes|libusb1|libusb1.0_0,libusb1.0-devel|exe,dev,doc,nls| #new replacement for libusb0
+yes|libusb0|libusb-compat0.1_4,libusb-compat0.1-devel|exe,dev,doc,nls| #compatibility lib for libusb0.
+yes|libva|libva1,libva-devel|exe,dev,doc,nls| #needed by ffmpeg
+yes|libvo|libvo-a*|exe,dev,doc,nls| #tainted. needed by ffmpeg. NOTICE Packages-mageia-1-official entries are broken NOTICE
+yes|libvorbis|libvorbis0,libvorbis-devel,libvorbisenc2,libvorbisfile3|exe,dev,doc,nls|
+yes|libvpx|libvpx0,libvpx-devel|exe,dev,doc,nls| #left out libvpx-utils
+yes|libwavpack|libwavpack1,libwavpack-devel|exe,dev,doc,nls|
+yes|libwmf|libwmf,libwmf0.2_7,libwmf-devel|exe,dev,doc,nls| #needed by abiword/wv
+yes|libwpd|libwpd0.9_9,libwpd-devel|exe,dev,doc,nls| #wordperfect import. needed by libreoffice
+yes|libwpg|libwpg-0.2_2,libwpg-devel|exe,dev>null,doc,nls| #wordperfect import. needed by libreoffice
+yes|libwrap|libwrap0,libwrap-devel|exe,dev,doc,nls|
+yes|libx86|libx86_1,libx86-devel|exe,dev,doc,nls|
+no|libxcb_base|libxcb1,libxcb-atom1,libxcb-aux0,libxcb-event1,libxcb-render0,libxcb-render-util0,libxcb-shape0,libxcb-shm0,libxcb-dri2_0,libxcb-xfixes0|exe,dev,doc,nls| #left out libxcb-devel -- it will need all libxcb-* pkgs installed, besides want to avoid compiling with libxcb.
+yes|libxcb_base|libxcb1,libxcb-atom1,libxcb-aux0,libxcb-event1,libxcb-render0,libxcb-render-util0,libxcb-shape0,libxcb-shm0,libxcb-dri2_0,libxcb-xfixes0,libxcb-devel|exe,dev,doc,nls|
+yes|libxml2|libxml2_2,libxml2-devel|exe,dev,doc,nls|
+yes|libxml2-utils|libxml2-utils|exe>dev,dev,doc,nls|
+yes|libxml2-python|libxml2-python|exe>dev,dev,doc,nls|
+yes|libxslt|libxslt1,libxslt-devel,xsltproc|exe,dev,doc,nls|
+yes|libyahoo2||exe,dev,doc,nls|
+yes|link-grammar|link-grammar,liblink-grammar4,liblink-grammar4-devel|exe,dev,doc,nls| #needed by abiword
+yes|linux_firewall||exe|
+yes|linux_firmware_dvb||exe|
+yes|linux_headers|linux-userspace-headers|exe>dev,dev,doc,nls| #mageia 2.6.38.7 kernel
+no|linuxtv-dvb-apps||exe,dev,doc,nls|
+yes|lirc|liblirc0,liblirc-devel|exe,dev,doc,nls| #infra-red control. more pkgs but i have only put in these libs. needed by mplayer, xine-ui, pulse-audio.
+no|lsb-base|lsb-core-lib,lsb-core-noarch,lsb-noarch,lsb-release|exe,dev,doc,nls| #do not know about this
+no|lxpanel||exe,dev>null,doc,nls|
+yes|m4|m4|exe>dev,dev,doc,nls|
+yes|madplay||exe,dev,doc,nls| #no mageia pkg
+yes|make|make|exe>dev,dev,doc,nls|
+yes|makedepend|makedepend|exe>dev,dev,doc,nls
+yes|makebootfat||exe| #must use my pet patched makebootfat.
+yes|man|man|exe>dev,dev,doc,nls|
+yes|man_cut||exe,dev>null,doc>null,nls>null|
+yes|metamail||exe,dev>null,doc,nls|
+yes|mesa_gl|libmesagl1,libmesagl1-devel|exe,dev,doc,nls #has libGL
+yes|mesa_swrast|libdri-drivers|exe,dev,doc,nls| #only want swrast_dri.so, see template.
+yes|mhwaveedit||exe|
+no|midori|midori|exe,dev,doc,nls| #browser. give this a go, instead of seamonkey.
+yes|mingetty|mingetty|exe,dev,doc,nls|
+yes|minixcal||exe|
+yes|mirdir||exe|
+yes|mkfontdir|mkfontdir|exe,dev,doc,nls|
+yes|mkfontscale|mkfontscale|exe,dev,doc,nls|
+yes|mktemp||exe,dev>null,doc,nls| #no mageia pkg
+yes|modem_stats||exe|
+yes|module-init-tools|module-init-tools,libmodprobe0,libmodprobe0-devel|exe,dev,doc,nls|
+yes|mountcifs||exe| #mageia pkg has many more deps
+yes|mp||exe| #no, the gtk mode of this mp is awful, use my curses-only pet.
+yes|mpage|mpage|exe,dev,doc,nls| #seems needed by foomatic-filters
+yes|mpc|libmpc2,libmpc-devel|exe>dev,dev,doc,nls|  #needed by gcc
+yes|mpfr|libmpfr4,libmpfr-devel,libmpfrcx1,libmpfrcx-devel,libmpfi0,libmpfi-devel|exe>dev,dev,doc,nls| #needed by gcc
+yes|mplayer_gui||exe,dev,doc,nls| #pet from wary5.
+yes|mplayer_codecs_basic||exe|
+yes|ms-sys||exe|
+yes|mscw||exe|
+yes|mtpaint||exe,dev,doc,nls|
+yes|mtr||exe|
+yes|multiarch-utils|multiarch-utils|exe>dev,dev,doc,nls| #needed by freetype.
+no|mut2||exe|
+yes|nasm|nasm|exe>dev,dev,doc,nls|
+yes|nbtscan||exe|
+yes|ncurses|ncurses,libncurses5,libncurses-devel,libncursesw5,libncursesw-devel|exe,dev,doc,nls|
+yes|ndiswrapper|ndiswrapper|exe,dev>null,doc,nls|
+yes|nenscript||exe|
+yes|netpbm|netpbm,libnetpbm10,libnetpbm-devel|exe,dev,doc,nls|
+no|netpbm||exe|
+yes|net_setup||exe|
+yes|net-tools|net-tools|exe,dev,doc,nls|
+yes|network_tray||exe|
+yes|nicoedit||exe| #our homegrown basic text editor, replacement for leafpad.
+yes|normalize|normalize|exe,dev,doc,nls|
+yes|notecase||exe| #mageia does not have this.
+yes|nspr|libnspr4,libnspr-devel|exe,dev,doc,nls| #these could also be builtin to a mozilla-based browser.
+yes|nss|libnss3,libnss-devel|exe,dev,doc,nls| #ditto
+yes|ntfs-3g|ntfs-3g|exe,dev,doc,nls|
+yes|ntfsprogs|ntfsprogs,libntfs10,libntfs-devel|exe,dev,doc,nls|
+yes|numlockx||exe| #needed by shinobars firstrun.
+no|obconf||exe,dev>null,doc,nls| #use with openbox
+no|openbox||exe,dev>null,doc,nls|
+yes|openjpeg|libopenjpeg2,libopenjpeg-devel|exe,dev,doc,nls|
+yes|openldap|openldap,libldap2.4_2,libldap2.4_2-devel|exe,dev,doc,nls|
+no|openslp|openslp,libopenslp1,libopenslp1-devel|exe,dev,doc,nls| #needed by mageia cups pkg.
+yes|opensp|OpenSP,libOpenSP5,libOpenSP5-devel|exe,dev,doc,nls| #needed by libofx
+yes|openssh_client|openssh-clients|exe,dev,doc,nls|
+yes|openssl|openssl,libopenssl1.0.0,libopenssl-devel,libopenssl-engines1.0.0|exe,dev,doc,nls|
+yes|orbit2|ORBit2,libORBit2_0,libORBit2-devel|exe,dev,doc,nls|
+yes|orc|orc,liborc0.4_0,liborc-devel|exe,dev,doc,nls|
+yes|osmo||exe,dev,doc,nls| #no mageia pkg.
+yes|ots|ots,libots1_0,libots-devel|exe,dev,doc,nls| #needed by abiword
+yes|pam|libpam0|exe,dev,doc,nls| #pam has many pkgs, i just want this lib to get by, do not actually use pam. problem it has deps.
+yes|pango|pango,libpango1.0_0,libpango1.0_0-modules,libpango1.0-devel|exe,dev,doc,nls|
+yes|parted|parted,libparted0,libparted-devel|exe,dev,doc,nls|
+yes|patch|patch|exe>dev,dev,doc,nls|
+yes|patchutils|patchutils|exe>dev,dev,doc,nls|
+no|pawdioconverter||exe|
+yes|pbackup||exe|
+yes|pburn||exe|
+yes|pcd||exe|
+yes|pcdripper||exe|
+yes|pciutils|pciutils,libpci3|exe,dev,doc,nls|
+yes|pciutils-devel|pciutils-devel|exe>dev,dev,doc,nls|
+yes|pcmciautils|pcmciautils|exe,dev,doc,nls|
+yes|pcre|pcre,libpcre0,libpcre-devel|exe,dev,doc,nls|
+no|pctorrent||exe|
+yes|pdvdrsab||exe|
+yes|perl|perl,perl-base|exe>dev,dev,doc,nls|
+yes|perl_tiny|perl,perl-base|exe,dev>null,doc>null,nls>null
+yes|perl-compress-zlib|perl-Compress-Raw-Zlib|exe>dev,dev,doc,nls| #is this the right pkg?
+yes|perl-digest-sha1|perl-Digest-SHA1|exe,dev>null,doc>null,nls>null|
+yes|perl-extutils-depends|perl-ExtUtils-Depends|exe>dev,dev,doc,nls|
+yes|perl-extutils-pkgconfig|perl-ExtUtils-PkgConfig|exe>dev,dev,doc,nls|
+yes|perl-html-parser|perl-HTML-Parser|exe,dev,doc,nls|
+yes|perl-mdk-common|perl-MDK-Common|exe,dev>null,doc>null,nls>null| #needed by initscripts
+yes|perl-uri|perl-URI|exe>dev,dev,doc,nls|
+yes|perl-xml-parser|perl-XML-Parser|exe>dev,dev,doc,nls| #needed by intltool
+yes|perl-xml-simple|perl-XML-Simple|exe>dev,dev,doc,nls|
+yes|pfilesearch||exe|
+yes|pfind||exe|
+yes|phash||exe
+yes|picocom||exe,dev,doc,nls| #no mageia pkg.
+yes|picpuz||exe|
+yes|picscale||exe|
+no|pictureviewer||exe|
+no|pilot-link|pilot-link-common,libpisock9,libpisock-devel|exe,dev,doc,nls| #needed by sylpheed
+yes|pixman|libpixman-1_0,libpixman-1-devel|exe,dev,doc,nls|
+yes|pkgconfig|pkgconfig|exe>dev,dev,doc,nls|
+yes|pmetatagger||exe|
+yes|pmirror||exe|
+yes|pmirrorget||exe|
+yes|pmusic||exe|
+yes|pmusic_tray||exe
+yes|pnethood||exe|
+yes|policykit|polkit,libpolkit1_0|exe,dev,doc,nls| #needed by gconf. would like to try and eliminate this pkg.
+yes|poppler|poppler,libpoppler13,libpoppler-glib6,libpoppler-cpp0,libpoppler-cpp-devel,libpoppler-devel,libpoppler-glib-devel,|exe,dev,doc,nls|
+yes|popt|popt-data,libpopt0,libpopt-devel|exe,dev,doc,nls|
+yes|powerapplet_tray||exe|
+yes|ppl|ppl-utils,libcloog0,libcloog-devel,libppl7,libppl_c2,libppl_c-devel,libppl-devel|exe>dev,dev,doc,nls| #needed by gcc
+yes|pplog||exe|
+yes|ppp||exe,dev>null,doc,nls| #mageia pkg needs libpam
+yes|pprocess||exe|
+yes|pptp|pptp-linux|exe,dev,doc,nls|
+yes|pupradio||exe|
+yes|prename||exe|
+yes|procps|procps|exe,dev,doc,nls|
+yes|programchooser||exe|
+yes|pschedule||exe|
+yes|psmisc|psmisc|exe,dev>null,doc,nls|
+no|pstopwatch||exe|
+no|pstreamvid||exe|
+yes|psync||exe|
+yes|ptimer||exe|
+no|ptooltips||exe|
+no|puppybrowser||exe|
+yes|puppyinputdetect||exe|
+yes|puppyphone||exe
+yes|puppy-podcast-grabber||exe|
+yes|puppyserialdetect||exe|
+yes|pupradio||exe,dev,doc,nls
+no|puptv||exe|
+yes|pupx||exe|
+yes|pure_ftpd||exe|
+yes|pwallpaper||exe|
+no|pwget||exe|
+no|pwireless||exe|
+yes|pwsget||exe|
+yes|pxlib|pxlib,libpx0,libpx-devel|exe,dev,doc,nls| #needed by gnumeric
+yes|python|python,libpython2.7|exe>dev,dev,doc,nls|
+no|python-libxml2|python-libxml2|exe>dev,dev,doc,nls| #no mageia pkg.
+yes|pzchmview||exe|
+yes|readline|libreadline6,libreadline-devel|exe,dev,doc,nls|
+no|replaceit||exe|
+yes|retrovol||exe|
+no|ripoff||exe| #no mageia pkg.
+yes|rman|rman|exe>dev,dev,doc,nls|
+yes|rox_filer||exe|
+no|rp_pppoe_cli|rp-pppoe|exe,dev,doc,nls|
+yes|rp_pppoe_cli||exe|
+yes|rpl||exe|
+yes|rsync|rsync|exe,dev,doc,nls|
+yes|rubix||exe|
+yes|rxvt-unicode||exe,dev>null,doc,nls|
+no|samba_client|samba-client,samba-common,libtalloc2,libtalloc-devel,libtdb1,libtdb-devel,libwbclient0,libwbclient-devel|exe,dev,doc,nls|
+yes|samba_client||exe|
+yes|sane-backends|sane-backends,libsane1,libsane1-devel,sane-backends-iscan|exe,dev,doc,nls|
+yes|scale2x||exe|
+yes|scanpci||exe| #needs library libpciaccesss (normally part of that pkg).
+yes|schroedinger|libschroedinger1.0_0,libschroedinger-devel|exe,dev,doc,nls| #alternative to dirac
+yes|seamonkey||exe,dev,doc,nls| #pet compiled for mageia
+no|seamonkey1||exe,dev,doc>null,nls>null
+no|seamonkey1_addon_adblock||exe
+no|seamonkey1_addon_copyplaintext||exe
+no|seamonkey1_addon_flashblock||exe
+no|seamonkey1_addon_fullerscreen||exe
+no|seamonkey1_addon_user_agent_switcher||exe
+no|seamonkey1_addon_video_downloadhelper||exe
+no|seamonkey1_addon_zombiekeys||exe
+yes|sed|sed|exe,dev>null,doc,nls|
+yes|setserial|setserial|exe,dev>null,doc,nls|
+yes|setvol||exe|
+yes|sfs-converter||exe|
+no|sgmixer||exe|
+yes|sgml-common|sgml-common|exe>dev,dev,doc,nls|
+yes|shared-mime-info||exe,dev|
+yes|showfont|showfont|exe,dev,doc,nls| #needed by x11-font-util
+yes|slang|libslang2|exe,dev,doc,nls| #libslang-devel
+no|sox|sox,libsox1,libsox-devel|exe,dev,doc,nls|
+no|soxgui||exe|
+yes|speex|speex,libspeex1,libspeex-devel|exe,dev,doc,nls|
+yes|sqlite|sqlite3-tools,libsqlite3_0,libsqlite3-devel|exe,dev,doc,nls|
+yes|squashfs-tools|squashfs3-tools|exe,dev>null,doc,nls|
+no|squashfs-tools4|squashfs-tools|exe,dev,doc,nls|
+yes|squashfs-tools4||exe|  #note, kernel-version sensitive.
+yes|ssh_gui||exe|
+yes|startup-notification|libstartup-notification-1_0,libstartup-notification-1-devel|exe,dev,doc,nls|
+yes|strace|strace|exe>dev,dev,doc,nls|
+yes|streamripper||exe,dev,doc,nls
+yes|subversion|subversion,libapr1,libsvn0,libapr-util1,subversion-tools|exe>dev,dev,doc,nls|
+yes|superscan||exe|
+no|sylpheed|sylpheed|exe,dev,doc,nls| #too many deps.
+no|sylpheed||exe,dev,doc,nls|
+yes|sys-freedos||exe|
+yes|sysfsutils|sysfsutils,libsysfs2,libsysfs-devel|exe,dev,doc,nls|
+yes|syslinux||exe,dev,doc,nls| #must use my pet.
+yes|sysprof||exe>dev,dev,doc,nls| #no mageia pkg.
+yes|sysvinit||exe| #my cutdown pet.
+yes|t1lib|t1lib-config,t1lib-progs,libt1lib5,libt1lib-devel|exe,dev,doc,nls| #needed by abiword mathview plugin
+yes|tar|tar|exe,dev>null,doc,nls|
+yes|texinfo|texinfo|exe>dev,dev,doc,nls|
+yes|tile||exe|
+yes|time|time|exe,dev>null,doc,nls|
+yes|transmission||exe,dev,doc,nls|
+yes|truncate||exe|
+yes|udev_167p||exe,dev,doc,nls|
+yes|unclutter||exe,dev>null,doc,nls| #no mageia pkg
+yes|unionfs_utils||exe|
+yes|unrar||exe,dev,doc,nls
+yes|unzip|unzip|exe,dev>null,doc,nls|
+yes|urxvtset||exe| #needs urxvt, yad
+yes|usb-modeswitch||exe|
+yes|usb-modeswitch-data||exe|
+yes|usbutils|usbutils|exe,dev,doc,nls
+yes|util-linux||exe,dev,doc,nls| #very suspicious, util-linux-ng fdisk very slow, roll back to old pkg.
+yes|v4l-utils|v4l-utils,libv4l0,libv4l-devel,libv4l-wrappers|exe,dev,doc,nls|
+yes|vala|vala,libvala0.12_0,libvala-devel,vala-tools|exe>dev,dev,doc>dev,nls|
+no|valide||exe>dev,dev,doc>dev,nls|
+yes|vamps||exe,dev,doc,nls| #no mageia pkg.
+yes|vcdimager|vcdimager,libvcd0,libvcd0-devel|exe,dev,doc,nls|
+yes|viewnior||exe|
+yes|vobcopy||exe,dev,doc,nls| #no mageia pkg
+yes|voikko|libvoikko1,libvoikko-devel|exe,dev,doc,nls| #needed by enchant
+yes|vorbis-tools|vorbis-tools|exe,dev,doc,nls|
+yes|waitmax||exe|
+no|wallpaper||exe|
+yes|wavplay||exe|
+yes|wcpufreq||exe|
+no|webkit|webkit,webkit1.0,libwebkitgtk1.0_2,libwebkitgtk1.0-devel,webkit-gtklauncher|exe,dev,doc,nls| #needed by midori, qt. TOO MANY DEPS
+yes|wget|wget|exe,dev>null,doc,nls|
+yes|wireless-tools|wireless-tools,libiw29,libiw29-devel|exe,dev,doc,nls|
+yes|wpa_supplicant|wpa_supplicant|exe,dev>null,doc,nls|
+yes|wv|wv,libwv-1.2_3,libwv-1.2_3-devel|exe,dev,doc,nls|
+yes|wvdial||exe|
+yes|x11proto|x11-proto-devel|exe>dev,dev,doc,nls|
+no|x264|libx264_110,libx264-devel|exe,dev,doc,nls| #tainted. needed by ffmpeg.
+yes|x264||exe,dev,doc,nls| #needed by my ffmpeg pet.
+yes|xarchive||exe,dev>null,doc,nls|
+yes|xclip||exe|
+yes|xcur2png||exe|
+yes|xdelta||exe|
+yes|xdg_puppy||exe|
+yes|xdialog||exe|
+yes|xfdiff-cut||exe|
+yes|xfprot||exe|
+yes|xkbconfigmanager||exe|
+yes|xlock_gui||exe|
+yes|xlockmore||exe| #cutdown pet.
+yes|xlsfonts|xlsfonts|exe,dev,doc,nls| #needed by x11-font-util
+yes|xml-core|xml-commons-apis,jpackage-utils,xml-commons-resolver|exe>dev,dev,doc,nls| #are these needed?
+yes|xorg_base|fontconfig,libfontconfig1,libfontconfig-devel,rgb,xcalc,xclipboard,xfontsel,xmessage,xload,x11-font-util,appres,editres,iceauth,lbxproxy,listres,luit,makedepend,proxymngr,rstart,setxkbmap,smproxy,viewres,x11perf,x11-scripts,xauth,xcmsdb,xconsole,xcursorgen,xdpyinfo,xev,xfindproxy,xfsinfo,xfwp,xgamma,xhost,xinit,xkbcomp,xkbevd,xkbprint,xkbutils,xkill,xlsatoms,xlsclients,xmodmap,xprop,xrandr,xrdb,xrefresh,xrx,xset,xsetmode,xsetpointer,xsetroot,xstdcmap,xtrap,xvidtune,xvinfo,xwininfo,x11-util-cf-files,x11-util-macros|exe,dev,doc,nls|
+yes|xorg_base_libs|libdmx1,libfontenc1,libfs6,libice6,liblbxutil1,liboldx6,libsm6,libwindowswm7,libx11_6,libxau6,libxaw7,libxcomposite1,libxcursor1,libxdamage1,libxdmcp6,libxevie1,libxext6,libxfixes3,libxfont1,libxfontcache1,libxft2,libxi6,libxinerama1,libxkbfile1,libxkbui1,libxmu6,libxpm4,libxrandr2,libxrender1,libxres1,libxscrnsaver1,libxt6,libxtrap6,libxtst6,libxv1,libxvmc1,libxxf86dga1,libxxf86misc1,libxxf86vm1,libdmx-devel,libfontenc-devel,libfs-devel,libice6-devel,liblbxutil-devel,liboldx6-devel,libsm6-devel,libwindowswm-devel,libx11_6-devel,libxau6-devel,libxaw-devel,libxcomposite1-devel,libxcursor-devel,libxdamage-devel,libxdmcp6-devel,libxevie-devel,libxext6-devel,libxfixes3-devel,libxfontcache1-devel,libxfont1-devel,libxft-devel,libxi-devel,libxinerama1-devel,libxkbfile-devel,libxkbui-devel,libxmu6-devel,libxpm-devel,libxrandr2-devel,libxrender1-devel,libxres1-devel,libxscrnsaver1-devel,libxt-devel,libxtrap-devel,libxtst6-devel,libxv1-devel,libxvmc1-devel,libxxf86dga-devel,libxxf86misc-devel,libxxf86vm-devel,x11-xtrans-devel|exe,dev,doc,nls| #see meta-pkg libxorg-x11, meta-pkg libxorg-x11-devel.
+no|xorg_base_xkb|x11-data-xkbdata|exe,dev,doc,nls| #temporary, xorg_base has a cutdown /etc/X11/xkb but not suitable for this xorg, so for now use this full pkg. no longer needed.
+yes|xsane|xsane|exe,dev>null,doc,nls|
+yes|xserver_xorg|x11-server,x11-server-common,x11-server-devel,x11-server-xorg,x11-driver-input-mouse,x11-driver-input-keyboard,x11-driver-input-synaptics,x11-driver-input-evdev,x11-driver-input-wacom,x11-driver-input-aiptek,x11-driver-video-*,-x11-driver-video-dummy,-x11-driver-video-glint,-x11-driver-video-ivtv,-x11-driver-video-nsc,-x11-driver-video-radeonhd,-x11-driver-video-tga,-x11-driver-video-vga,-x11-driver-video-fglrx,-x11-driver-video-nvidia173,-x11-driver-video-nvidia96xx,-x11-driver-video-nvidia-current,-x11-driver-video-fbdev,-x11-driver-video-psb,-x11-driver-video-qxl,-x11-driver-video-vmware,-x11-driver-video-vmlegacy,-x11-driver-video-xgi,-x11-driver-video-xgixp|exe,dev,doc,nls|
+no|xorg-server||exe,dev,doc,nls| #i compiled this in mageia1.
+no|xorg-server-no_udev||exe,dev,doc,nls| #i compiled this in mageia1.
+no|xserver_xorg|x11-driver-input-mouse,x11-driver-input-keyboard,x11-driver-input-synaptics,x11-driver-input-evdev,x11-driver-input-wacom,x11-driver-input-aiptek,x11-driver-video-*,-x11-driver-video-dummy,-x11-driver-video-glint,-x11-driver-video-ivtv,-x11-driver-video-nsc,-x11-driver-video-radeonhd,-x11-driver-video-tga,-x11-driver-video-vga,-x11-driver-video-fglrx,-x11-driver-video-nvidia173,-x11-driver-video-nvidia96xx,-x11-driver-video-nvidia-current,-x11-driver-video-fbdev,-x11-driver-video-psb,-x11-driver-video-qxl,-x11-driver-video-vmware,-x11-driver-video-vmlegacy,-x11-driver-video-xgi,-x11-driver-video-xgixp|exe,dev,doc,nls|
+yes|xsoldier||exe|
+yes|xvidcore|libxvid4,libxvid-devel|exe,dev,doc,nls|
+yes|xz|xz,liblzma5,liblzma-devel|exe,dev,doc,nls|
+yes|yad||exe,dev,doc,nls|
+yes|yaf_splash||exe|
+yes|yasm|yasm|exe>dev,dev,doc,nls|
+yes|ycalc||exe|
+yes|you2pup||exe|
+yes|zfind||exe|
+yes|zip|zip,libzip,libzip1,libzip-devel|exe,dev,doc,nls|
+no|zlib||exe,dev,doc,nls| #weird, mageia pkg uses libuclibc.
+yes|zlib|libzlib1,libzlib-devel|exe,dev,doc,nls| #well, it does use uclibc, as well as glibc.
+'

Changes to woof-distro/x86/mageia/cauldron/DISTRO_SPECS

@@ -1,1 +1,14 @@
-
+#One or more words that identify this distribution:
+DISTRO_NAME='Drake Puppy'
+#version number of this distribution:
+DISTRO_VERSION=0.4
+#The distro whose binary packages were used to build this distribution:
+DISTRO_BINARY_COMPAT='mageia'
+#Prefix for some filenames: exs: drakesave.2fs, drake-puppy-4.99.0.sfs
+DISTRO_FILE_PREFIX='drake'
+#The version of the distro whose binary packages were used to build this distro:
+DISTRO_COMPAT_VERSION='cauldron'
+#the kernel pet package used:
+DISTRO_KERNEL_PET='linux_kernel-3.2.17-pae-i686-aufs-w5.pet'
+#read by /usr/bin to bypass Xorg Wizard at first boot:
+DISTRO_XORG_AUTO='yes'

Changes to woof-distro/x86/ubuntu/precise/DISTRO_PKGS_SPECS-ubuntu-precise

@@ -102,10 +102,11 @@
 yes|cyrus-sasl2|libsasl2-2,libsasl2-dev|exe,dev,doc,nls
 no|dbus|dbus,libdbus-1-3,libdbus-1-dev|exe,dev,doc,nls|+lsb-base
 no|dbus-glib|libdbus-glib-1-2,libdbus-glib-1-dev|exe,dev,doc,nls|+dbus
 yes|dbus||exe,dev,doc,nls
 yes|dbus-glib||exe,dev,doc,nls
+yes|d-conf|dconf-gsettings-backend,dconf-service,libdconf0,libdconf-dbus-1-0|exe,dev,doc,nls| #needed by gsettings-desktop-settings
 yes|ddcprobe||exe,dev>null,doc,nls
 yes|debianutils|debianutils|exe,dev,doc,nls
 yes|defaults-chooser||exe|
 yes|desk_icon_theme_blue_moon||exe
 no|desk_icon_theme_jq8flat||exe
@@ -199,11 +200,11 @@
 yes|ghostscript||exe,dev,doc,nls
 yes|gifsicle|gifsicle|exe,dev>null,doc,nls
 no|gins||exe,dev>null,doc,nls
 yes|git|git-core,gitweb,git-doc|exe>dev,dev,doc>dev,nls>dev
 yes|glade3|glade,libgladeui-2-0|exe>dev,dev,doc,nls
-yes|glib|libglib2.0-0,libglib2.0-data,libglib2.0-dev|exe,dev,doc,nls
+yes|glib|libglib2.0-bin,libglib2.0-0,libglib2.0-data,libglib2.0-dev|exe,dev,doc,nls
 yes|glibc|libc-bin,libc6,libc6-dev,tzdata|exe,dev,doc,nls
 yes|glibc_locales|locales|exe,dev,doc,nls>exe
 no|glibc_i18n_en||exe
 yes|glibmm|libglibmm-2.4-1c2a,libglibmm-2.4-dev|exe,dev,doc,nls
 yes|glipper||exe,dev>null,doc,nls
@@ -224,10 +225,11 @@
 yes|gphotofs|gphotofs|exe,dev,doc,nls
 yes|gpptp||exe
 yes|grep|grep|exe,dev>null,doc,nls
 yes|groff|groff|exe>dev,dev,doc,nls
 yes|grub|grub|exe,dev>null,doc,nls
+yes|gsettings-desktop-schemas|gsettings-desktop-schemas|exe,dev,doc,nls| #needs d-conf.
 yes|gsm|libgsm1,libgsm1-dev|exe,dev,doc,nls
 yes|gtk+|libgtk2.0-0,libgtk2.0-dev|exe,dev,doc,nls
 yes|gtk2-engines-pixbuf|gtk2-engines-pixbuf|exe,dev,doc,nls
 yes|gtkam|gtkam|exe,dev>null,doc,nls|
 yes|gtk-chtheme|gtk-chtheme|exe,dev>null,doc,nls

Changes to woof-distro/x86/ubuntu/precise/DISTRO_SPECS

@@ -7,9 +7,9 @@
 #Prefix for some filenames: exs: precisesave.2fs, precise-4.99.0.sfs
 DISTRO_FILE_PREFIX='precise'
 #The version of the distro whose binary packages were used to build this distro:
 DISTRO_COMPAT_VERSION='precise'
 #the kernel pet package used:
-DISTRO_KERNEL_PET='linux_kernel-3.2.13-pae-i686-up.pet'
+DISTRO_KERNEL_PET='linux_kernel-3.2.17-pae-i686-aufs-w5.pet'
 #read by /usr/bin to bypass Xorg Wizard at first boot:
 DISTRO_XORG_AUTO='yes'
 DISTRO_TARGETARCH='x86'