Quirky Pi 8.1.3 Service Pack


As promised, from Quirky 8.1.2, upgrades will be available as Service Packs, small PET packages. At least, for as long as I am motivated to do so!

You need to have 8.1.2 running on your Pi2 or Pi3:
http://barryk.org/news/?viewDetailed=00457

The 8.1.2-to-8.1.3 Service Pack is here (21MB):
http://distro.ibiblio.org/quirky/quirky6/armv7/packages/pet_packages-xerus/service_pack-8.1.2_TO_8.1.3-xerus.pet

You could download it and click on it to install. Alternatively, a check is made for a Service Pack whenever the Puppy Package Manager is started, or a check may be made via the menu "Filesystem/Quirky Version Upgrade Manager".

What is new in 8.1.3
I have compiled the Linux kernel, now version 4.4.34. various small changes, including both 8192cu.ko and rtl8192cu.ko drivers -- this is for experimenting with wifi dongles that use that chip, and one of those drivers will have to be blacklisted.

We will experiment and get this wifi chip going!

Tex Dog in the Puppy Forum reported that the 'xrefresh' utility is missing, used by omxplayer. Fixed.

Uninstalling
PET package uninstalling in Quirky is introduced here:
http://barryk.org/news/?viewDetailed=00032

This means that you should be able to uninstall the 8.1.3 Service Pack, and be rolled back to 8.1.2.
However, I have not yet verified that it works.

Ongoing discussion
http://murga-linux.com/puppy/viewtopic.php?t=108132&start=390


No comments posted yet