More imported, getting there


I have been reporting on the ongoing effort to import source packages into OpenEmbedded:
http://barryk.org/news/?viewDetailed=00572

This morning, imported these:
libgd
metamail
mhwaveedit
minixcal


There's a dejavu thing going on here, as I went through this exercise later 2014, for T2, for example see this blog post:
http://barryk.org/news/?viewDetailed=00140

I see 'gwhere' listed back then. failed this time, put it in the too-hard basket for now. Some packages are inherently cross-compiler-unfriendly. Ditto for 'inkscapelite'.

T2 is different, it has a non-cross-compile mode (if host and target archs are the same), then able to chroot into the target rootfs. This enables gwhere and inkscapelite to compile.


Comments:

Add more   Posted on 15 Jun 2017, 16:50 by admin
Updating the list of imported packages:

mirdir mpscan nbtscan libgnomecanvas libxscrnsaver makedepend whois xcalc xclipboard xvidtune patchutils picscale planner powerapplet-tray

Planner was a challenge, took about two hours. technosaurus created a patch for it sometime ago, to remove dependency on gconf. I have gconf in my build, so that doesn't matter. There were some more patches from debian.
The configure script still looked for gconf, also looked for libgnomeui and scrollkeeper -- just fooled it that they are there, and it compiled.
haven't tested whether it runs yet!

Note, planner does need libgnomecanvas. Scrollkeeper, that's one I am uncertain about, it was deprecated sometime ago, in favour of rarian, but I have neither in my build.


Not getting there   Posted on 14 Jun 2017, 19:12 by admin
I imported a few more, then went through all packages, made a list of what still needs to be imported to OE ... 63 packages.

I recall, when did it for T2, imported well over 100, might have been around 130.

I can still keep using those packages compiled in T2, but really want to get them all imported to OE.

Oh well, will keep at it.